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Úvodem  
Flash je program pro vytváření interaktivních 

animací. Je to program, který si získal a stále získává 
nové příznivce pro svoji jednoduchost na jedné straně 
a rozsáhlé možnosti na straně druhé. Tato publikace 
z řady PCWorld Edition je zaměřena na rychlý úvod 
do použití Flashe a to pouze jedné z jeho stránek – 
zvládnutí základních technik práce bez použití 
ActionScriptu, tedy bez možností interaktivity. 

Pro začínající uživatele Flashe je ale především 
nutné pochopit práci s programem, který má svoje 
specifické nástroje a možnosti, které sice mohou mít 
ekvivalenty v jiných aplikacích, ale používají se třeba 
poněkud odlišným způsobem. 

Základem této publikace je představení pracovního 
prostředí Flashe, ukázka použití základních nástrojů, 
vysvětlení práce s časovou osou, rámečky a dalšími 
specifiky Flashe. Značná pozornost je věnována 
symbolům a vytváření jejich instancí, práci 
s vrstvami... Závěr publikace tvoří několik ukázek 
základních postupů, které musí zvládnout každý 
uživatel tohoto mocného nástroje.  

Zaměření těchto publikací máte v rukou i vy sami. 
Podívejte se na anketu na www.win.cz nebo 
www.idg.cz, kde můžete svým hlasem ovlivnit témata 
dalších připravovaných sešitů ediční řady PCWorld 
Edition. 

Svoje připomínky, náměty a poznámky zasílejte:  
UNIS Publishing, s.r.o. 
Jundrovská 33, 624 00 Brno 
tel.: 05 – 41 51 55 00    fax: 05 – 41 51 55 02 
e-mail: knihy@win.cz 
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Začínáme s programem FLASH 5 
Dříve, než se pustíme do vlastního programu, mám jedno upozornění pro ty, kteří program FLASH ne-

vlastní. Na stránce www.macromedia.cz nebo přímo na www.digitalmedia.cz/macromedia si můžete stáhnout 
třicetidenní plnou verzi tohoto programu. Můžete také použít kopii programu, která je umístěna na CD 
v PCWorldu 4/2001.  

 
Po instalaci a spuštění programu použijte tlačítko Try ke spuštění zkušební verze. Tlačítko Buy Now 

slouží k zakoupení produktu v internetovém obchodě a platbě kartou v dolarech. Pro nákup v tuzemsku si 
prohlédněte výše uvedené internetové adresy. 

Než otevřete FLASH 
Jako u celé řady jiných aplikací, i v případě programu FLASH je nutné pro zdárný postup prací na va-

šem projektu: 
• znát prostředí aplikace, se kterou pracujete, umět používat jednotlivé nástroje a vědět, kdy a které 

z těchto nástrojů použít 
• mít jasnou představu o díle, které vytváříte. Čím mlhavější tato představa bude, tím déle se bude-

te dopracovávat k výsledku. 
Animace vytvářené v programu FLASH nejsou bezpodmínečně určeny pro web, ale jejich využití je zde 

nejčastější. Před tím, než se rozhodnete pro vytvoření animovaných webových stránek (nebo alespoň strá-
nek s animovanými prvky), je důležité ujasnit si co a pro koho vytváříte. Animace by měla být integrovanou 
a přirozenou součástí stránek, a ne cizorodým, pouze efektním prvkem, který návštěvníka při dalších přístu-
pech na vaši stránku již nezaujme a naopak bude zdržovat. 
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Při každé práci mějte dobře rozvržený cyklus: 

PLÁN – ZÁMĚR  NÁVRH 
co a pro koho se vytváří, co má být 
v centru pozornosti;, vyhodnocení stávající 
situace; co a jak dělá konkurence; finance 

 skicy, grafické návrhy a náměty, vytvoření 
„image“ stránek, jiné ukázky a tipy, shro-
máždění podkladů 

   
IMPLEMENTACE  VYTVOŘENÍ 

přenesení na webový server, dokončení 
testování a uvedení do provozu 

 realizace předchozích kroků za pomoci 
vhodných nástrojů, vytvoření funkčního 
prototypu a jeho testování,  

 Pokud hledáte inspiraci, nabízíme jednak domácí zdroj: www.flashzone.cz nebo slovenskou 
www.flashland.sk, případně zahraniční ukázky, například stránky: www.macromedia.com/software/flash, 
7up.com, www.atomfilms.com/, www.flashcentral.com/Xena3/Index.htm, http://www.mach3.com/, http://disney. 
go.com/DisneyChannel/ZoogDisney/... 

Nyní ale všechno přeskočíme a podíváme se na jeden z nástrojů, který máte pro tvorbu webových strá-
nek k dispozici – program FLASH. 

Pracovní prostředí 
Po spuštění programu se zobrazí základní pohled na prostředí aplikace FLASH 
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Celá řada prvků i jejich rozvržení je vám jistě dostatečně známá, například uživatelům Photoshopu. 
V rychlosti se ale na jednotlivé objekty podíváme. 

Panel nástrojů 
Standardně je panel nástrojů umístěn u levého okraje okna aplikace. Tažením za volnou plochu mezi 

tlačítky nebo za nadpisy jednotlivých dílčích částí (Tools, View...) můžete tento panel umístit na jiné libo-
volné místo. Jak vidíte, je panel nástrojů rozdělen na čtyři části: Tools, View, Colors a Options. V části 
Tools jsou uvedeny vlastní grafické nástroje. Část View obsahuje nástroje umožňující upravovat zobrazení. 
Nástroje uvedené pod nadpisem Colors slouží k nastavení barev. Poslední část panelu je nadepsána Options 
a v ní se budou zobrazovat individuální možnosti nastavení pro jednotlivé vybrané nástroje. 

 

Tools 
Tato část zahrnuje řadu známých nástrojů:  

 

 

Nástroj Arrow (šipka pro celkový výběr) umožňuje pracovat 
s objektem jako celkem, ale má další nastavení: 

 

Snap to object – přichytávání k objektům. 
Pokud je zapnuto, budou se při tažení 
objekty přichytávat k jiným objektům. Toto 
tlačítko může být zapnuto nebo vypnuto. 

 

Smooth / Strighten (hladký / přímý) – při 
vybraném objektu klepnutím na nástroj 
Smooth vyhladíte obrys, klepnutím na 
nástroj Strighten linii obrysu vyrovnáte.  

 

Rotate / Scale (natočení / zvětšení) – 
slouží k pootočení, případně zkosení, nebo 
změně velikosti označeného objektu. 

 

 

Nástroj Subselect (šipka pro dílčí výběr) umožní vybrat jednotlivé uzly obrysových 
křivek a manipulovat s nimi. Tento nástroj nemá k dispozici další nastavení 
Options. 

 

Nástroj Line (přímka) slouží ke kreslení úseček nebo lomených čar. Pro tento 
nástroj nejsou k dispozici další nastavení v panelu Options. Vlastnosti kreslených 
čar se nastaví pomocí panelu Stroke (viz dále). 

 

 

Nástroj Lasso (laso) použijete pro určení hranice výběru, se 
kterým budete dále pracovat, např. přemístit. Základním 
módem je vytýčení hranice výběru volným tažením od ruky. 
V panelu Options najdete další možnosti: 

 

Magic Wand (magická hůlka) – 
v bitmapových obrázcích slouží k výběru 
oblastí podobných barev. K nastavení 
citlivosti použijte Magic Wand Properties. 

 

Magic Wand Properties – umožní nastavit 
citlivost výběru podobných barev v bitmapě 
pomocí kouzelné hůlky  

 

Polygon mode (mnohoúhelníkový výběr) – 
změní výběr volným tažením kurzoru na 
výběr tvořený mnohoúhelníkem 
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Nástroj Pen (pero) je vhodný pro kreslení lomených čar nebo čar složených 
z beziérových křivek. Pro nastavení vlastností použijte panel Stroke (viz dále). 

 

Nástroj Text slouží k napsání textu do obrázku. I v tomto případě se pří výběru 
nástroje nezobrazí žádné nastavitelné vlastnosti, máte ale k dispozici tři panely: 
Character, Paragraph a Text Options. 

 

Nástroj Oval (ovál) použijete pro kreslení kružnic a elips. Pro nastavení barvy 
výplně a provedení obrysové křivky využijete panely Fill a Stroke (viz dále). 

 

Nástroj Rectangle (obdélník) umožní kreslit obdélníky a čtverce. Pro nastavení 
výplňové barvy a obrysové čáry použijte panely Fill a Stroke. 
Jedinou volbou v Properties je Round Rectangle Radius: 

 

Tlačítkem Round Rectangle Radius (poloměr zaoblení rohu) 
otevřete dialogové okno, ve kterém můžete nastavit zaoblení rohu 
obdélníka zadáním hodnoty poloměru zaoblení v obrazových bodech. 

 

 

Nástroj Pencil (tužka) doplňuje nástroje Line a Pen o možnost kreslení čar podle 
ruky. V panelu Properties je jediné nastavení, kterým můžete měnit mód kreslení: 

 

Všimněte si malého černého trojúhelníka v dolním pravém rožku 
ikony – stiskněte kurzor na tlačítku a podržte. Otevře se další 
nabídka, která obsahuje jednotlivé módy kreslení. K dispozici jsou:  

 

 

Straighten (přímý) – kreslená čára bude 
sestávat z přímých úseků. 
Smooth (hladký) – roztřesená čára 
kreslená podle ruky bude vyhlazena. 
Ink (inkoust, stopa) – čára bude odpovídat 
skutečné stopě, kterou tužka při volném 
kreslení od ruky zanechá.  

 

 

Nástroj Brush (štětec) k nanášení barev na plochu. Pro nastavení vlastností 
štětce jsou k dispozici volby v části Properties: 

 

Na použití nástroje štětec se ještě podrobněji podíváme, 
zde uvedu pouze význam jednotlivých nastavení: 
Brush Mode (mód štětce) – můžete vybrat z celkem pěti 
nastavení počínaje přemalováním všeho až po malování 
pouze na pozadí. 
Brush Size (velikost štětce) – nabízí nastavení tloušťky 
štětce v celkem 10 stupních. 
 
Brush Shape (tvar štětce) – v seznamu najdete paletu 
devíti různých tvarů štětce, které zanechávají různé stopy. 
 
Lock Fill (uzamknout výplň) – použije se v případě, že 
malujete barevným přechodem nebo bitmapovým 
obrázkem. Ukážeme si později. 

 

 

Nástroj Ink Bottle (lahvička inkoustu) slouží pro změny, překreslení obrysových 
čar, křivek, polygonů apod. Vlastnosti čar se nastaví v panelu Stroke. 
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Nástroj Paint Bucket (kbelík s barvou) umožní vyplnit – vylít – barvou uzavřenou 
oblast. Oblast nemusí být ale zcela uzavřená, v nastavení Properties můžete určit 
velikost mezery, při které se bude i otevřená oblast považovat za uzavřenou.  

 

První tlačítko – Gap Size (velikost mezery) – umožní nastavit 
přípustnou velikost mezery, aby se oblast ještě považovala 
za uzavřenou a mohla být vyplněna nástrojem Paint Bucket. 
Dole jsou uvedeny další dvě nastavení, obě se týkají výplní 
pomocí přechodů nebo bitmapových obrázků. 
Levé tlačítko – Lock Fill (uzamknout výplň)  
Pravé tlačítko – Transform Fill (přetvořit, upravit výplň) – 
umožní posouvat nebo natáčet výplň tažením polohovacích 
bodů, které se zobrazí po klepnutí na výplň. 

 

 

Nástroj Dropper (kapátko) je určen k „nabrání“ barvy z existujícího objekt. Po 
nabrání barvy se ikona kurzoru změní na ikonu Paint Bucket (kbelík barvy) nebo 
na Ink Bottle (lahvička inkoustu) podle toho, odkud jste barvu nabrali – zda 
z vybarvené  plochy nebo obrysové křivky. Kapátko umožňuje také sejmout jako 
barevný vzorek celou bitmapu, jak si dále ukážeme. 

 

Nástroj Eraser (guma) použijete, když budete chtít vygumovat některé části 
obrázků. Pokud chcete odstranit veškerý obsah jeviště, poklepejte na tlačítko 
Eraser. Tento nástroj má následující možnosti nastavení: 

 

 

Eraser Mode (mód gumování) – zde lze 
nastavit, co se bude gumovat: vše, výplň, 
obrys... 

 

Faucet (kohoutek) – odstraní vše, na co 
kurzorem klepnete. 

 

Eraser Shape (tvar gumy) –ze seznamu 
si můžete vybrat velikost i tvar nástroje, 
kterým budete gumovat.    

 

Část View (pohled) obsahuje dva nástroje, pomocí kterých můžete upravovat pohled na 
jeviště: 

 

Nástroj Hand (ruka) umožní přesunutí jeviště na pracovní ploše. Vyberte nástroj 
a tažením umístěte jeviště (nebo jeho zobrazenou část) do nové polohy. 

 

Nástroj Zoom (transfokace) slouží k nastavení velikosti zobrazování jeviště. V části 
Properties můžete zvolit jeden ze dvou módů: 

 
Ikona se symbolem + slouží ke zvětšování pohledu, ikona se 
symbolem – ke zmenšování.   

 

Část Colors (barvy) obsahuje základní nástroje pro nastavení barev. 
První tlačítko nastavuje barvy pro kreslení čar, křivek a obrysů, druhé tlačítko nastavuje barvy 
výplní. Vedle vlastního nástroje, který symbolizuje použití (tužka nebo kbelík s barvou), je 
barevná ploška zobrazující aktuální nastavení barvy. Klepnete-li na ni, dostanete se do dialogu, 
ve kterém můžete přímo nastavit požadovanou barvu. Stejné, nebo podrobnější nastavení 
můžete provést v ukotvitelném panelu Mixer nebo Swatches. Blíže se k práci s barvami 
dostaneme dále.  



Z a č í n á m e  s  p r o g r a m e m  F L A S H  5  

7 

 
Default Colors – tímto tlačítkem nastavíte implicitní barvy: černá barva pro čáry a bílá 
pro výplně 

 
No Colors (bez barvy) – při kreslení objektů můžete vypnout kreslení obrysu nebo 
výplně. Vyberte nástroj pro kreslení (ovál nebo obdélník), klepněte na tlačítko pro 
barvu obrysu nebo výplně a potom na tlačítko NoColor. Tím jsme potlačili zobrazování 
vybrané části kresleného objektu. 

 
Swap Color (prohoď barvy) – zamění barvy pro kreslení obrysu a výplně. 

 

Plovoucí panely 
Většinu nastavení pracovních nástrojů budete provádět pomocí plovoucích panelů. Pokud se panely na 

pracovní ploše nezobrazují, otevřete jejich seznam příkazem Window > Panels: 

 

- Info: poskytuje základní informace o rozměrech, poloze a barvách 
objektu. Informuje také o aktuální poloze kurzoru. 

- Fill: informace a nastavení výplní. 
- Stroke: informace a možnost nastavení obrysových linek, křivek 

a čar. 
- Transform: základní nástroje pro změnu velikosti, tvaru nebo 

natočení objektu. 
- Align: obsahuje několik sad tlačítek pro rychlé zarovnání 

a uspořádání objektů na jevišti. 
- Mixer: umožňuje namixovat libovolnou barvu pro výplně i čáry 
- Swatches: barvu můžete vybírat z připravených vzorníků 
- Character: panel pro nastavení písma a jeho základních vlastností 
- Paragraph: obsahuje nastavení pro úpravu odstavců textu 
- Text Options: zde můžete nastavit řadu vlastností textu, jako 

např. zda může uživatel  text upravovat, zda bude text na jednom 
nebo více řádcích, přidat k textu URL apod. 

- Instance: informuje o nastavení a umožňuje nastavit vlastnosti 
aktuálně vybrané instance (konkrétní případ použití) symbolu. 

- Effect:  nastavení efektů pro rámeček animace. 
- Clip Parameters: přístup k informacím o tzv. smart clips 

(šikovných, elegantních klipech), které umožňují do animace 
snadno začlenit interaktivní prvky,  jako rozbalovací seznam atd. 

- Frame: obsahuje vlastnosti a nastavení pro konkrétní rámeček 
animace 

- Sound: v tomto panelu lze vybrat zvuk, který se bude přehrávat 
s animaci a nastavit některé hodnoty, jako synchronizaci, počet 
opakování apod. 

- Scene: v tomto panelu můžete snadno kopírovat, vytvářet nové, 
měnit pořadí nebo odstraňovat nepotřebné scény.  

- Generator: vztahuje se k produktu Macromedia Generator, kterým 
se zde nebudeme zabývat. 

Jednotlivé panely si představíme postupně při ukázkách práce. Poznamenávám, že ekvivalentem práce 
s panelem jsou příkazy jednotlivých nabídek. Například pro práci s textem můžete používat jak nástroje pa-
nelů Character, Paragraph nebo Text Options, ale také příkazy nabídky Text z pruhu nabídek, např. Text > 
Font pro nastavení druhu písma apod. 

Výhodou panelu je to, že ho máte stále při ruce, a že různá nastavení jsou přehledně pohromadě na jed-
nom místě. Nevýhodou je skutečnost, že zejména na menší obrazovce (nebo při nižším rozlišení) zabírají 
panely velkou část pracovní plochy. 

Při práci s panely můžete využívat možnosti ukotvení panelu, tj. automatického přichycení k okraji okna 
aplikace nebo k jinému panelu. Jinou možností, jak ušetřit místo je minimalizovat velikost panelu – postačí 



M a c r o m e d i a  F L A S H  5  

8 

poklepat na titulek panelu a zobrazí se pouze titulek a záhlaví jednotlivých karet, které jsou na panelu umís-
těny. Opětovným poklepáním se celý panel rozvine do plné velikosti. 

  
Jinou možností, jak ušetřit místo, je vyskládat si vlastní panely. Pokud např. používáte často pouze ně-

které z karet na panelech, můžete si je přetáhnout na jeden vlastní panel. Uchopte záhlaví karty, kterou chce-
te z panelu použít, a přetáhněte ji mimo panel.  Na obrázku je ukázka takto poskládaného panelu. 

 

Drobnou nevýhodou je to, že panel zachovává standardní 
velikost, ať je v něm jedna karta nebo karet několik. Pokud 
tedy do panelu přetáhnete více karet, zmenší se jejich 
záložky, případně až na velikost samotné ikony.  

Pokud se vám podařilo vytvořit nastavení, které vám plně vyhovuje, uložte si ho. Použijte příkaz Win-
dow > Save Panel Layout. Zobrazí se jednoduché dialogové okno, ve kterém zadáte pouze název sestavy 
panelů. Nadále již budete moci toto uspořádání používat jako jedno z přednastavených a vyvolat je příka-
zem Window > Panel Sets a vybráním příslušného názvu uspořádání ze seznamu. Pokud se budete chtít vrá-
tit k původnímu uspořádání plovoucích panelů, použijte podobně příkaz Window > Panel Sets a zvolte 
možnost Default Layout. 

 

V této nabídce máte možnost vybrat některé z vlastních uspořádání panelů, nebo 
se vrátit k původními nastavení. 
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Grafika 
V programu Flash můžete pro vytváření animací používat obrázky vytvořené mimo Flash a importovat 

je. Grafické možnosti Flashe jsou však dosti silné na vytvoření vlastních obrázků. Kdy sáhnout po možnosti 
importu a kdy tvořit obrázek přímo v programu Flash? Do jisté míry to závisí na vašich zkušenostech 
a praxi. Pokud jste velmi zruční v jiných programech (Photoshop, FreeHand, Illustrator...) můžete vytvořit 
obrázky mimo Flash a importovat je. Pokud ale nedisponujete těmito programy, nebo dobře zvládáte i práci 
s nástroji Flashe, která má přece jenom svá specifika, nic vám nebrání připravit obrázky přímo ve Flashi. Je 
samozřejmé, že možnosti Flashe nedosahují zcela schopností, kterými disponují specializované aplikace na 
tvorbu kreseb, ale i přes svoji na první pohled chudou nabídku budete možná překvapeni tím, co vše dokáží. 
Pokud zvolíte možnost importu, dávejte pozor na to, ve které verzi výsledky práce ukládáte.  

Flash podporuje import souborů v těchto grafických formátech: 
 

typ souboru grafika zdrojová aplikace poznámka 
.ai vektorová Illustrator Illustrator do verze 6.0, ne novější. Po importu 

je třeba obrázek rozdělit na části. 
.fh7, .fh8, .fh9 
.ft7, .ft8, .ft9 

vektorová FreeHand Pro import lze doporučit především verzi 7. 

.dxf vektorová AutoCAD Použijte pouze soubory do verze 10. Nepodpo-
rují se výplně ploch, soubor musí být v ASCII 
tvaru. 

.emf, .wmf metafile   
.eps postscript   

.bmp, .gif, 
.jpg, .png,.pic 

bitmapová  Formáty .gif a .png umožňují pracovat 
s průhledným pozadím. 

.psd bitmapová Photoshop Vyžaduje nainstalovaný QuickTime 4.0 
.tif, .tgf, .pict bitmapová  Vyžaduje nainstalovaný QuickTime 4.0 

 
Pokud není uvedena aplikace, můžete příslušný formát obdržet jako variantu uložení nebo exportu gra-

fiky z různých aplikací. Pokud např. používáte program CorelDRAW, můžete grafiku z tohoto programu 
exportovat do všech zde uvedených formátů (mimo vlastní formát Photoshopu .psd). 

Při importu může v jednotlivých případech dojít k řadě různých problémů – u vektorové grafiky mohou 
dělat potíže přechodové výplně nebo přechody tvarů, stejně jako vrstvy apod. Obecně se doporučuje použí-
vat pro import grafiku z aplikace FreeHand, která ale zase u nás nepatří mezi nejrozšířenější. V případě po-
tíží zkuste nejprve změnit formát souboru, nebo importovat po částech, po jednodušších objektech, a některé 
úpravy provést až ve Flashi (přechodové výplně...).  

Kdy použít bitmapu a kdy vektorovou grafiku? Bitmapová grafika se hodí zejména pro pozadí, pro ba-
revné výplně, nebo pro vytvoření dílčích částí animovaných objektů. Její použití má určité nevýhody – pře-
devším velikost souborů. Obecně je bitmapový obrázek mnohem větší než obrázek vektorový. (Nemohu se 
zde zabývat detaily, ale doporučuji naši knihu Skenování, úprava obrázků a tisk (UNIS Publishing, 2000) 
nebo Grafika a animace – kouzla na webu (UNIS Publishing, 2000).) Další nevýhodou je neprůhlednost 
„objektů“ v bitmapách. Bitmapa, ať je jejím obsahem cokoliv, je vždy tvořena obdélníkovou maticí obrazo-
vých bodů. Výjimkou je formát GIF, který dovoluje definovat jednu barvu jako průhlednou, případně formát 
.psd (interní formát Photoshopu), který ale pro import vyžaduje nainstalovaný QuickTime 4.0 a navíc lze 
importovat pouze staré verze – 2 a 3, současná verze 6, ani předchozí 5 nebo 5.5 podporovány nejsou.  Mezi 
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nevýhody bitmap lze také uvést závislost vzhledu bitmapy na zvětšování nebo zmenšování. V zásadě 
s každou změnou velikosti dochází ke ztrátě grafické informace. Na druhou stranu je ale třeba říci, že tyto 
ztráty se významněji projeví skutečně až při velkých změnách, nebo na ostře vykreslených okrajích, které se 
stávají zubatými. 

Pro import grafiky je možné doporučit především obrázky ve formátech, které podporují bezztrátovou 
kompresi (viz uváděna publikace Skenování, úprava obrázků a tisk). Flash provede vlastní komprimaci, kte-
rá je optimalizována právě pro jeho potřeby a je proto efektivnější. Z tohoto důvodu jsou např. obrázky for-
mátu .bmp (PC) nebo .pict (MAC) výhodnější než např. formát .jpeg, který používá ztrátovou kompresi. 

Naopak mezi výhody importu bitmap lze zařadit schopnost rozeznání sady souvisejících obrázků podle 
jejich jmen končících pořadovým číslem a jejich automatický společný import. Stejně tak zachová Flash po 
importu i kanál Alpha (pokud ho podporuje příslušný formát), tj. bude zachována např. i nastavená průhled-
nost. Alpha kanály podporují formáty .psd, .tiff, .pict a .png. Pokud nemáte QuickTime 4.0 a chcete praco-
vat s kanálem Alpha, je třeba použít formát .png, který je jinak nezaslouženě stranou pozornosti uživatelů, 
protože ho nepodporují některé starší webové prohlížeče. Obecně jsou bitmapy vhodnější pro obrázky, 
u kterých potřebujete vystihnout velké množství barev, např. barevné fotografie. U bitmapy může mít každý 
obrazový bod jinou barvu. Na rozdíl od toho u vektorového obrázku se barva výplně generuje podle určité-
ho schématu, např. jako lineární výplň, a je velmi obtížné vystihnout zejména jemné změny, na které jsme 
zvláště citliví, např. přirozené změny v barvách obličeje. 

Existuje ale i možnost vzájemného převodu vektor – bitmapa (tzv. rastrování) a obráceně bitmapa – vek-
tor (tzv. trasování, vektorizace). Ve Flashi, který je přirozeně vektorovou aplikací podporující práci 
s bitmapami, nás bude zajímat spíše druhý postup, tedy převod bitmapy na vektorový obrázek – trasování 
(anglicky trace bitmap).  

Import bitmap 
Dříve, než se pustíte do importu bitmap, je vhodné si uvědomit některé skutečnosti: 

• čím více bitmap importujete do Flashe, tím bude vytvářený soubor větší; 
• před importem upravte velikost, tj. rozměr udaný v obrazových bodech, podle potřeby. Uvědomte si, že 

animace, kterou vytváříte, se bude prohlížet na obrazovce, většinou v rozlišení 800 x 600 bodů, možná 
1024 x 768 asi ne ve větším, spíše můžete počítat s rozměrem 640 x 480. Je tedy zbytečné importovat 
obrázky obsahující více obrazových bodů. Je jedno, který z grafických editorů používáte, zda pracujete 
s Photoshopem, PhotoPaintem, PaintShop Pro, ACDSee nebo Gimp... Každý z těchto programů umí 
„převzorkovat“ obrázek, tj. změnit počet obrazových bodů (pixelů). Pokud budete potřebovat pro 
animaci obrázek, který budete zobrazovat zhruba ve velikosti ¼ obrazovky, tj. cca 200 x 150 obrazových 
bodů, je zbytečné importovat obrázek o rozměrech 1000 x 750 pixelů. Nedosáhnete vyšší kvality 
obrázku, a poměr velikostí nekomprimovaného obrázku je 1 : 25! Větší obrázek obsahuje 25krát více 
obrazových bodů, než menší obrázek. A přitom při zobrazení budou prostě nadbytečné body vypuštěny. 

• upravte počet barev v obrázku a barevný model. Obrázky pro prohlížení by měly být uloženy v RGB ba-
revném modelu. Pokud chcete zajistit, aby se obrázky dobře zobrazovaly na většině prohlížečů a na vět-
šině grafických karet, použijte tzv. webovou paletu. Obecně vám model RGB umožňuje při 24bitové 
barevné hloubce použít 16,5 mil. barev. Starší grafické adaptéry ale mohou pracovat třeba jenom s 256 
barvami. Tzv. webová paleta obsahuje celkem 216 barev, zbytek do 256 je rezervován pro základní barvy 
Windows a Mac.  
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• ujasněte si, zda budete pracovat s průhledností. Pokud ano, máte v podstatě tři možnosti: použít bitma-
pové formáty GIF nebo PNG, nebo použít převod na vektory. Tento převod (trasování) můžete provést 
jak externě, tak i po importu bitmapy ve Flashi. 

• určitou zvláštností je import animovaných GIFů. Tyto soubory obsahují vlastně několik obrázků, které 
jsou po natažení do prohlížeče postupně zobrazovány a tím vzniká dojem pohybu, animace. Každý 
z obrázků uložených v souboru .gif bude umístěn do samostatného rámečku. 

• pokud budou obrázky v adresáři označeny pořadovými čísly (např. obr001.bmp, obr002.bmp, 
obr003.bmp atd.), dotáže se Flash při importu, zda si přejete importovat celou tuto řadu. 

 
Pokud chcete importovat celou skupinu obrázků, klepněte na tlačítko Ano. Tento postup se hodí třeba 
pro import jednotlivých obrázků videa apod. 
 
Vlastní import provedete příkazem File > Import.  
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Podívejte se na předchozí obrázek, na kterém je situace po importu jedné bitmapy. Jak vidíte, bitmapa se 
umístila na jeviště do právě aktuální pracovní vrstvy. Současně se provedl záznam do knihovny (Library), 
z jejíhož panelu je nyní tento obrázek dostupný. Pokud ho budete tedy potřebovat použít i na jiném místě 
v animaci, můžete ho již bez importu vytáhnout přímo z okna knihovny. (Okno Library zobrazíte příkazem 
Window > Library.) Knihovna je rozdělena na dvě části, v dolní je seznam objektů (importovaných obrázků 
a symbolů), v horní části je náhled označené položky.  Tlačítko Options (volby) vám dává k dispozici celou 
řadu příkazů, na některé z nich se postupně podíváme.  

Pokud máte zobrazen panel Info, vidíte zde i základní údaje o bitmapě – název, velikost a umístění. Po-
třebujete-li další podrobnosti o tomto obrázku, použijte buďto výše zmíněné tlačítko Options panelu Library 
a vyberte příkaz Properties. Nebo můžete klepnout pravým tlačítkem na název obrázku v seznamu v dolní 
polovině panelu Library a vyberte příkaz Properties. Nejrychlejší cestou je poklepat na náhled obrázku 
v knihovně Library. 

 

 

V dialogovém okně Bitmap Properties vidíte údaje o souboru zdroje obrázku – název, umístění, rozmě-
ry, hloubku barev – a některé možnosti, jak bude Flash s tímto obrázkem pracovat. Můžete požadovat vy-
hlazování hran při úpravách velikosti (políčko Allow smoothing), nebo nastavit druh komprimace. 
K dispozici je ztrátová komprese JPEG, která je vhodná pro fotografie, nebo bezztrátová komprese (zde je 
označena jako LossLess (GIF/PNG)), která je vhodná pro malované obrázky. V případě JPEG komprese 
můžete použít vlastní nastavení – ponechejte volné políčko Use imported JPEG data a budete moci nastavit 
kvalitu obrázku v rozmezí 0-100% (100% je nejvyšší kvalita). 

Tlačítkem Test si zobrazíte výsledky nastavené komprese, tj. původní velikost a dosaženou velikost ob-
rázku. Nezapomeňte na to, že JPEG komprese je ztrátová, obrázek se barevně degraduje. Nenechejte se mý-
lit tím, že po úpravě nedojde k žádné výrazné změně. Abyste se podívali na skutečné výsledky, budete 
muset animaci spustit (např. příkazem Control > Play nebo příkazem Control > Test Movie).  

Podívejte se na dva následující obrázky: vlevo je obrázek, kde je zvolena „rozumná“ hodnota komprese, 
vpravo je nastavena příliš vysoká hodnota komprese a obrázek je zcela znehodnocen. 

Pokud potřebujete bližší informace k uvedené problematice, doporučuji některou z našich publikací: 
Velká kniha Photoshop 5.5, Skenování, úprava obrázků a tisk nebo Grafika, animace – kouzla na webu. 
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Práce s bitmapami 
Jakmile jste bitmapový obrázek importovali, můžete s ním provádět celou řadu činností: zvětšovat, 

zmenšovat, měnit tvar... podobně jako s grafikou, kterou vytváříte  Pro změny umístění, velikosti a tvaru 
použijte nástroj šipka (Arrow). 

  
Pro přesun postačí klepnout na obrázek, kolem něj se zobrazí šedivý okraj a můžete obrázek přesouvat 

tažením na libovolné místo. Pro změnu velikosti vyberte nástroj Arrow a zapněte vlastnost Scale v části 
Properties panelu nástrojů:          . Podobně pro otáčení a zkosení musíte přidat tlačítko Rotate:  
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Pokud potřebujete s bitmapami provádět jiné úpravy, použijte příkaz Modify > Break Apart. Tím převe-
dete bitmapu z podoby bitmapového obrázku na výplň tvaru. Bitmapa se v tomto případě stane pouze 
zvláštním případem barvy, můžete ji používat po natažení kapátkem jako jakoukoliv jinou barvu. Pokud ka-
pátkem klepnete na bitmapový obrázek, nasaje barvu přímo z místa, kam jste klepli. V případě Bitmapy 
převedené příkazem Break Apart bude nasáta celá bitmapa a ta nyní tvoří vzorek barvy. K tomuto použití se 
ale dostaneme blíže u popisu práce s barvami, zde je jenom ukázka obou případů: 

  
Na levém obrázku je původní importovaná bitmapa. Kapátkem proto nasajete skutečně jenom barvu 

z místa, kde kapátkem klepnete. Kreslený objekt má nyní barvu odpovídající jednomu místu bitmapy. 
Druhý případ, vpravo, je sejmut po převedení bitmapy příkazem Break Apart. V tomto případě se již ne-

jedná o bitmapový obrázek, ale o bitmapovou výplň – do kapátka je nasáta celá bitmapa a nové objekty bu-
dou mít stejnou výplň. V podstatě je po nasátí kapátkem jakoby celá pracovní plocha pokryta vzorkem 
vyskládaným z bitmapy. Každý objekt, který nakreslíte pouze odkryje průhled na tento podklad. Podívejte 
se na následující obrázek, který ukazuje celý mechanismus: 

 

Jak vidíte na obrázku, 
nakreslené objekty 
(elipsa a tři obdélníky) 
skutečně tvoří pouze 
jakýsi průhled na 
vzorek vyskládaný 
z původní bitmapy. 
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Pokud chcete do výplně umístit nějakou konkrétní část bitmapy, postupujte takto: 

• umístěte na jeviště bitmapu, kterou chcete použít 
pro výplň (příkazem File > Import nebo přetaže-
ním obrázku z knihovny Library); 

• příkazem Modify > Break Apart „rozbijte“ bit-
mapu; 

• nasajte bitmapu jako barvu kapátkem; 
• nakreslete objekt, který potřebujete – jako výplň 

je použita právě bitmapa; 
• klepněte na nástroj kbelík s barvou a v části Pro-

perties na tlačítko Transform Fill 
• klepněte na nakreslený objekt a uvidíte kolem něj 

(v originále modrý) obdélník s polohovacími bo-
dy; 

• tažením těchto bodů můžete upravit velikost, po-
lohu, natočení, a tvar výplně.  

  
Vymezující rámeček má celkem 7 polohovacích bodů, každý z nich má jinou funkci: 

• střední kruhový bod: slouží ke změně polohy vzorku vzhledem k objektu; 
• horní bod uprostřed: umožňuje vodorovné zkosení vzorku 
• pravý bod uprostřed: tažením provedete svislé zkosení 
• rohový bod vpravo nahoře: slouží k otáčení vzorku kolem středu 
• levý bod uprostřed: tažením upravíte šířku vzorku 
• dolní bod uprostřed: je určen pro úpravu výšky vzorku 
• rohový bod vlevo dole: slouží k diagonální úpravě velikosti  

Pokud při úpravách velikosti přetáhnete polohovací body obdélníka přes střed, provedete i převrácení 
(zrcadlení) vzorku.  

Po převodu bitmapy na výplň (Modify > Break Apart) můžete upravovat i tvar bitmapy jako jakoukoliv 
jinou výplň, jak je popsáno v další části.  
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Bitmapa ale nemusí ani po importu do programu Flash zůstat bitmapou. Nevýhodou bitmap je poměrně 
velká velikost souboru a určitá omezení, která máte při další práci s bitmapou narozdíl od práce 
s vektorovou grafikou. Flash nabízí možnost převodu bitmapy na vektorovou grafiku, tzv. vektorizaci nebo 
trasování (anglicky Trace) bitmap. 

Bitmapu umístěnou na jevišti (např. po importu nebo přetažením z knihovny) můžete převést do vekto-
rové podoby příkazem Modify > Trase. 

 
Po spuštění příkazu se zobrazí dialogové okno, ve kterém můžete nastavit parametry řídící proces traso-

vání. Následující řada obrázků ukáže vliv jednotlivých parametrů na výsledné zobrazení: 
Color Treshold (práh barev) – nastaví citlivost rozlišování barev. Hodnota se zadává v rozsahu 0-500. Čím 
menší hodnotu zadáte, tím citlivější bude posuzován rozdíl barev a tím barevně podobnější obrázek obdržíte. 
Současně ale narůstá počet vektorových obrázků, které jsou pro popis bitmapy třeba. 

Color Treshold = 20 Color Treshold = 50 Color Treshold = 100 
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Minimum Area (minimální oblast): rozsah oblasti, ze které se vzorek barev posuzuje. Udává se v pixelech. 
Čím menší hodnotu zadáte, tím kvalitnější přiblížení dostanete. Při vzorkování se použije průměrná barva 
z oblasti dané počtem pixelů. Na obrázku si všimněte např. změn u nápisu na rámu rakety nebo na uchu 
tenistky, případně i tvar oblouku rakety.  

Minimum Area = 1 pixel Minimum Area = 10 pixel Minimum Area = 50 pixel 

  
Curve Fit (sledování křivek): ze seznamu můžete vybrat přesnost, s jakou se mají sledovat ostré kontrastní 
hrany v obrázku. Nejpřesnější sledování křivek dosáhnete zvolením hodnoty Pixels (sledovat tvar křivky na 
úrovni obrazových bodů), nejvolnější výsledek obdržíte po zadání Very Smooth ( velmi hladké). Při tomto 
nastavení nesleduje vytvářený vektorový obrys žádné dílčí jemné změny obrysu, ale všechny křivky budou 
vyrovnávány.  
Corner Treshold (práh zubů): zadáváte, jak se mají sledovat ostré lokální změny. Pokud z rozbalovací ho 
seznamu zadáte Many Corners, budou vektory sledovat drobné lokální ostré změny. Pokud zadáte hodnotu 
Few Corners, budou tyto lokální změny vyhlazeny.   

 
Optimální nastavení záleží vždy na charakteru obrázku, který trasujete. Současně je ovlivněno i poža-

davky na velikost souboru. Nemá smysl volit vždy co nejpřesnější a nejjemnější nastavení. V některých pří-
padech je nastavení velmi citlivé od určité hranice a do ní se změny v obrázku příliš neprojeví. Čím více 
vektorových objektů se bude vykreslovat, tím delší čas bude animace potřebovat pro vlastní běh a tím bude 
také velikost jejího souboru větší.  

Kvalita výsledku trasování závisí i na použitém formátu bitmapy. Je třeba si uvědomit, že je např. velký 
rozdíl mezi možnosti formátu GIF a JPEG. Není to dáno pouze počtem barev, ale i způsobem, jak jsou ba-
revné odstíny v obrázku tvořeny. Podívejte se na poslední ukázku týkající se bitmap. Vlevo je výsledek tra-
sování souboru GIF (velikost souboru 116 kB) a vpravo JPEG (velikost souboru 33 kB): 
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Kreslicí nástroje 
Program Flash disponuje na první pohled velmi chudou nabídkou nástrojů pro kreslení. Dříve, než se na 

ně podíváme, několik základních informací: 
- grafika, kterou přímo vytváříte v aplikaci Flash, je vektorová. Je tedy tvořena jednotlivými ob-

jekty, které mohou mít obrys a mohou mít výplň. 
- výplň i obrys se chovají jako samostatné objekty, ne tak, jak jste zvyklí třeba z CorelDRAW, kde 

výplň a obrys jsou vlastnostmi objektu jako takového, a nemůžete je od sebe oddělit. Můžete 
pouze nastavit nulovou tloušťku obrysové čáry, nebo „žádnou“ barvu výplně.  

- pokud pracujete v rámci jedné vrstvy, potom objekty stejné barvy se spojují dohromady do jed-
noho objektu a naopak objekty různých barev se „odečítají“. 

- vedle nakreslené grafiky existuje možnost (a pro animace nutnost) převedení grafiky na tzv. 
symbol. 

- při kreslení je možné využít schopnosti rozpoznávat tvary a převádět křivé čáry a čáry od ruky na 
přímky a hladké křivky, stejně tak i od ruky kreslené a různě pokřivené obdélníky a elipsy. 

- nově podporuje nástroj Pen (pero) i práci s bezierovými křivkami 

Nastavení barev a barevné přechody 
Než se pustíme do vlastní práce, je zapotřebí si říci, jak se nastaví barvy, které budete při kreslení použí-

vat.  Základní nastavení provedete v panelu nástrojů v části Color: 

 

Jak vidíte, můžete nastavit jak barvu pro obrysy, tak i barvu, kterou se budou kreslit 
výplně. Spodní tři tlačítka umožňují: 
- nastavit předdefinované barvy, tj. černá a bílá 
- pro nástroje obdélníka a elipsa lze potlačit barvu jak obrysu, tak i výplně 
- prohodit barvu výplně a obrysu. 
Pro nastavení barvy klepněte na barevnou plochy vedle ikony tužky (barva obrysu) nebo 
plechovky (barva výplně) a dostanete se do palety barev. Kapátkem můžete nabrat 
některou z přednastavených barev. K dispozici máte několik možností, jak barvy vybrat: 
na levém okraji vzorníku barev je svislý pruh obsahující základní barvy modelu RGB 
a CMY, tedy červenou, zelenou, modrou, azurovou, purpurovou a žlutou. Nad nimi jsou 
odstíny šedé v kroku 20% od bílé (0%) až po černou (100%).  Hlavní plocha vzorníku je 
tvořena barvami webové palety. Tato paleta obsahuje 216 barev, které by měly být vždy 
věrně v prohlížeči zobrazeny, a to jak na platformě Mac, tak i Windows. 
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Levý obrázek na předchozí straně odpovídá nastavení barev pro obrysové čáry, pravý pro barvy výplní. 
Jak vidíte, pro výplně jsou k dispozici i barevné přechody (zleva doprava): lineární šedý, radiální šedý a tři 
radiální pro složky RGB, lineární chromový a poslední je lineární duhový přechod. Později si ukážeme po-
kročilejší možnosti nastavení přechodů. 

Vedle těchto přednastavených barev můžete použít i jiné barvy z celkového počtu 16,7 mil. barev, které 
dokáže popsat RGB model. Vlastní barvu můžete zvolit celou řadou postupů. Pokud stále pracujete v okně 
vzorníku barev, můžete přímo napsat hodnoty jednotlivých R-G-B složek.  

 

U horního levého okraje je políčko, ve kterém je uveden číselný 
kód, v mém případě #33CC66. Tento kód vyjadřuje zastoupení 
jednotlivých složek R-G-B v konkrétní barvě. Údaj rozdělte po 
dvojicích (bez symbolu #) a převeďte z 16kové soustavy. V tomto 
případě by to bylo: 
složka R – 3316 = 3  x 16 + 3 = 51 
složka G – CC16 = 12 x 16 + 12 = 204 
složka B – 6616 = 6 x 16 + 6 = 102 
Jedná se tedy o barvu RGB(51,204,102). 

Obráceně, pokud byste chtěli přidat některou jinou barvu, např. barvu firemního loga, musíte si převést 
její složení RGB do šestnáctkové soustavy. Např. barva Pantone 338 CVC má složení RGB(149,218,190). 
Pro převod použijete buďto kalkulátor nebo následující tabulku: 
 

 0 1 2 3 4 5 6 7 8 9 A B C D E F 
0 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 

1 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 

2 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 

3 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 

4 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 

5 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 

6 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 

7 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 

8 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 

9 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 

A 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 

B 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 

C 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 

D 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 

E 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 

F 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 
 

Hodnotu, kterou chcete převést z desítkové soustavy do šestnáctkové si najdete v tabulce a zjistíte od-
povídající hodnotu na levém svislém a horním vodorovném okraji. Pro 149 bychom odečetli vlevo 9 a naho-
ře 5. V desítkové soustavě 149 je tedy 95 v šestnáctkové soustavě. Podobně by bylo 21810 = DA16 resp. 
19010 = BE16. Uvedenou barvu bychom tedy do textového pole zapsali jako #95DABE.  

Jinou možností je použít dialog Color (Barva), který se otevře po klepnutí na ikonu barevného kruhu 
v pravém horním rohu vzorníku: 
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To, že je tento 
dialog česky, 
neznamená, že 
mám českou 
verzi Flashe. 
V tomto případě 
se používá 
dialog 
Windows. 

Zde můžete definovat vlastní barvu tak, že ji buďto přímo nastavíte kombinací tažení kurzoru v barevné 
ploše a táhla u svislého pruhu. V barevné ploše vybíráte barevnou složku a ve svislém pruhu světelnost (tj. 
množství bílé). Můžete i přímo zadat hodnotu RGB, tentokrát bez přepočtu do šestnáctkové soustavy. (Dru-
hé údaje o složení barev – Odstín, Sytost a Světelnost se týkají barevného modelu HSB. Pokud se potřebuje-
te blíže seznámit s těmito pojmy, doporučuji naši publikaci Skenování, úprava obrázků a tisk.) 

Pokud chcete barvu nadále používat, uložte si ji tlačítkem Přidat do vlastních barev.  
Flash ale nabízí další možnosti, jak nastavit barvy, kterými budete kreslit. Podívejte se na panel Mixer 

a panel Swatch (vzorník): 

  

Jak nahoře vidíte, máte zde k dispozici podobné 
možnosti jako na panelu nástrojů, ale je zde přímo 
dostupná možnost zadání RGB složek barvy 
(v desítkové soustavě) a také barevný pruh, ve 
kterém můžete barvu přímo klepnutím vybrat. Ve 
směru zleva doprava se mění barevnost, shora dolů 
se mění zastoupení bílé barvy. 

Panel Swatches nabízí výběr barvy z přednastavené 
webové palety, podobně jako při nastavení barev 
z panelu nástrojů. 
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Na obrázku panelu Mixer si ještě povšimněte políčka Alpha (je umístěno pod složkami RGB na pravém 
okraji panelu). Standardně je zde nastavena hodnota 100%, která označuje barvu jako zcela neprůhlednou. 
Snižováním hodnoty dolů zvyšujete průhlednost barevného vzorku. Hodnota 0% odpovídá zcela průhledné 
barvě, tato barva tedy nebude překrývat objekty pod ní. Pozor, toto nastavení platí pro pohledy mezi 
vrstvami, ne mezi objekty v téže vrstvě, jak si dále ukážeme.  

Je třeba upozornit ještě na jednu vlastnost panelu Mixer. Pokud chcete přidat barvu jako vzorek do 
vzorníku, použijte nabídku panelu: 

 

Klepněte na symbol  nahoře na pravém 
okraji panelu. Otevře se nabídka panelu 
a z ní vyberte příkaz Add Swatch (přidat 
vzorek).  

 

Budete-li nyní vybírat barvu ze vzorníku (zde je použit přímo 
panel Swatches), uvidíte tyto přidané barevné vzorky dole 
pod standardní paletou barev. 
 
 
 
 
 
 
Barvu do vzorníku můžete přidat i pomocí nabídky panelu 
Swatches. Nabídku rozbalíte klepnutím na symbol  nahoře 
na pravém okraji panelu. 

 

V této nabídce najdete celou 
řadu příkazů: 
- Duplicate Swatch (duplikuj 

vybraný vzorek) 
- Delete Swatch (zrušit vzorek) 
- AddColors (přidat barvy 

z externího souboru) 
- Replace Color (přepsat barvy 

z externího souboru) 
- Load Default Color (obnovit 

přednastavené barvy) 
- Save Color (uložit aktuální 

vzorník barev) 
- Save as Default (uložit jako 

přednastavené barvy) 
- Clear Colors (vymazat barvy) 
- Web 216 (vytvořit vzorník 

z webové palety – obnovit 
původní nastavení) 

- Sort by Color (setřídit podle 
barev) 
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Pro detailní nastavení vlastností čar a obrysů použijte panel Stroke (tah): 

 

Na tomto panelu můžete nastavit veškeré vlastnosti 
obrysů a čar.  
Především je to barva (pomocí ikony Stroke Color – 
barva tahu). 
Dále je možné také  nastavit tloušťku tahu a druh 
čáry. 

Podobně můžete použít pro práci s výplní panel Fill: 

 

Toto na první pohled jednoduché okno v sobě skrývá 
překvapení. Standardně je nastavena výplň jako plná (Solid). 
V rozbalovacím seznamu máte ale ukryty další možnosti: 

 
Vedle None (žádná výplň) zde můžete definovat Linear 
Gradient (lineární přechod), Radial Gradient (kruhový 
přechod a Bitmap (bitmapu jako výplň).  

  

Postup vytvoření lineárního barevného přechodu je následující: 
• Otevřete panel Fill (výplň) – klepněte na ouško karty Fill v zobrazeném plovoucím panelu, nebo použijte 

příkaz Window > Panels > Fill. 
• Z rozbalovacího seznamu vyberte položku Linear Gradient. 
• Na ploše panelu se zobrazí čtyři nové grafické symboly; zleva to jsou: ukázka vytvořeného barevného 

přechodu, pruh pro definici gradientu, ikona pro nastavení barev a dole ikona pro uložení přechodu. 
• Změnu výchozí nebo koncové barvy přechodu upravíte tak, že klepnete na jednoho z krajních jezdců ve 

tvaru čtverečku s trojúhelníkovou čepičkou. Ve čtverečku je zobrazena aktuální barva. Trojúhelník uka-
zuje na místo, ve kterém bude tato konkrétní hodnota barvy nastavena. Trojúhelníček vybraného jezdce 
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je černý, nevybraného jezdce bílý. Jakmile jezdce označíte, můžete klepnutím na ikonu s barevným ob-
délníkem vpravo otevřít barevný vzorník a nastavit barvu. 

• Tažením jezdce můžete upravit i polohu počátku nebo konce barevného přechodu. Pokud posunete např. 
levý jezdec směrem doprava, bude část přechodu od levého okraje až po pozici jezdce vyplněna pouze 
nastavenou barvou jezdce. 

 

Na obrázku vlevo jsou oba krajní jezdce přitaženy k sobě 
a lineární přechod bude v tomto případě tvořen vlastně 
pouze zcela černým a zcela bílým pruhem. 

• Lineární přechod můžete dále upravovat vložením dalších jezdců dovnitř mezi krajní jezdce. Stačí klep-
nout pod barevný proužek a přidali jste nového jezdce. Jezdce odstraníte snadno přetažením jezdce dolů 
od proužku.  

 

Pro každý jezdec můžete nastavit vlastní barvu a tak 
vytvořit přechod přesně podle svých představ. 

• Pokud potřebujete uvnitř přechodu vytvořit pouze jednobarevnou oblast, musíte přidat dva jezdce se 
stejnou barvou, které určují počátek a konec takového úseku: 

 

Na obrázku vlevo je přechod, který má uprostřed zcela 
černou část a krajní třetiny jsou tvořeny lineárním 
přechodem do bílé. 

• Klepnutím na tlačítko s ikonou diskety uložíte tento přechod do vzorníku barev – Swatches – (nikoli na 
disk) pro další použití. 
 
Postup vytvoření radiálního přechodu je podobný: 

 

Ze seznamu vyberte položku Radial Gradient a získáte 
zobrazení podobné tomu, které jsme si vysvětlili u lineárního 
přechodu. 
Jediný rozdíl je v tom, že v ukázce zobrazení vidíte skutečně 
radiální přechod (tedy změnu barev ze středu směrem ven. 
Na proužek pro definici gradientu se dívejte jako na výřez 
s tím, že levý okraj odpovídá středu gradientu a pravý okraj 
odpovídá okraji gradientu. 
Stejným postupem, jako u lineárního gradientu můžete měnit 
barvy, upravovat jejich rozložení a dle potřeby tak upravit 
vlastní radiální přechod. 
I v tomto případě můžete nastavení přechodu, který chcete 
opakovaně používat, uložit klepnutím na tlačítko s ikonou 
diskety vpravo dole. Přechod bude uložen do barevného 
vzorníku.   

Poslední položkou v rozbalovacím seznamu nastavení výplně panelu Fill je Bitmap. To vám poskytuje 
možnost použít kterýkoliv importovaný bitmapový obrázek jako výplň. Postup práce je velmi jednoduchý. 
Nejprve musíte importovat vhodný bitmapový obrázek do Flashe pomocí příkazu File > Import. Podívejte 
se do předchozí kapitolky na podporované formáty. 

Po importu jsou bitmapy uloženy v knihovně (Library), kterou můžete vyvolat příkazem Windows > Li-
brary. V minulé kapitole jsme si ukázali práci s bitmapami a možnost použití bitmapy převedené příkazem 
Modify > Break Apart jako barevného vzorku. Tuto možnost máte v podstatě i bez tohoto příkazu. Podívejte 
se na panel Fill.  
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Na obrázku vlevo je 
nakreslen obdélník a elipsa 
s barevnou výplní. 
V otevřeném panelu Fill 
byla vybrána 
z rozbalovacího seznamu 
položka Bitmap a tím jsme 
se dostali k seznamu 
uložených bitmapových 
vzorků.  
Tyto vzorky se zde zapsaly 
po importu bitmap, bez 
toho, že by byly rozbity 
příkazem Modify > Break 
Apart. 

 

V dalším kroku jsem použil 
kbelík s barvou na 
přebarvení výplně jednou 
z vybraných bitmap. 
U obdélníka vidíte, že je 
vytvořen opakující se 
vzorek, který je možné dále 
upravit. 

 

Po výběru nástroje Paint Bucket (kbelík s barvou) z panelu 
nástrojů klepněte na tlačítko Transform Fill dole v části 
Properties panelu nástrojů. Klepněte na výplň, kterou chcete 
upravovat,  a můžete tažením za polohovací body obdélníka, 
který se zobrazí kolem jednoho vzorku, upravovat tvar, velikost 
i polohu vzorku. Připomínám pouze, že každý polohovací bod 
má svoji specifickou funkci.  
Kruhové body ve středech stran nahoře a vpravo slouží ke 
zkosení, čtvercové body ve středech stran mění velikost 
v daném směru. Dolní rohový bod mění velikost se zachováním 
poměru stran a horní rohový bod slouží k otáčení. 
Pomocí středního bodu můžete vzorek posouvat. 
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Základní nástroje pro kreslení 

Obdélník, elipsa, přímka 
Pro kreslení obdélníků použijete nástroj Rectangle z panelu nástrojů. Klepněte na něj a tažením na pra-

covní ploše vykreslíte obdélník. Podobně pro kreslení elips použijte nástroj Oval z panelu nástrojů. 
Oba dva nástroje kreslí zadanou barvo výplně a zadanou barvou a druhem čáry obrysu.  

 

Pokud chcete nakreslit čtverec nebo 
kružnici,zapněte přimykání k objektům (příkaz 
View > Snap to Object) a  táhněte kurzor myši 
přibližně pod úhlem 45°. Malé kolečko, které 
při tažení sleduje kurzor myši, se zvýrazní na 
znamení toho, že se vytváří čtverec nebo kruh. 
Jakmile se kurzorem více vzdálíte od úhlu 45°, 
zmenší se kolečko do původní velikosti 
a kreslíte obdélník nebo elipsu přesně 
odpovídající poloze kurzoru.. 

Při kreslení nástrojem Line z panelu nástrojů kreslíte přímé čáry. Umístěte kurzor do počátečního bodu 
úsečky, stiskněte tlačítko myši a táhněte kurzor do koncového bodu. Jakmile tlačítko myši uvolníte, čára se 
vykreslí. Pokud hned znovu stisknete tlačítko myši, můžete pokračovat v kreslení lomené čáry do dalšího 
uzlu. Jakmile přemístíte kurzor myši bez stisknutého tlačítka myši, čáru jste přerušili a můžete začít kreslit 
novou čáru z jiného počátečního bodu. Při kreslení čar pod úhlem 45° můžete použít klávesu Shift. V tomto 
případě je nutné nejprve ukončit kreslení a teprve potom uvolnit klávesu Shift. Pro kreslení svislé nebo vo-
dorovné čáry můžete, podobně jako u obdélníka a čtverce, pokud máte zapnuto přimykání k objektům pří-
kazem View > Snap to Object, sledovat velikost referenčního bodu – pokud bude zvýrazněný, kreslíte pod 
úhlem 45°. 

Pravítka, mřížka, vodítka a přimykání k objektům 
Pro kreslení, ale i při manipulaci s objekty, můžete používat pravítka, mřížku a vodítka. Pravítka zobra-

zíte nebo skryjete příkazem View > Rulers. Z pravítek můžete vytáhnout svislá nebo vodorovná vodítka 
(Guide). Vodítka, která jste si připravili, můžete zobrazit nebo skrýt příkazem View > Guide > Show 
Guides. Pokud jsou vodítka skryta, zobrazí se automaticky jakmile vytáhnete ze svislého nebo vodorovného 
pravítka další vodítko.  

V případě vodítek můžete nastavit i jejich vlastnosti. Příkazem View > Guides > Edit Guides se dostane-
te do dialogového okna, ve kterém můžete nastavit: 

 

Dialogové okno pro nastavení vlastností vodítek 
– Guides. 

• Color – barvu, jakou se vodítka budou zobrazovat 
• Show Guides – zobrazit vodítka 
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• Snap to Guides – přichytávat k vodítkám 
• Lock Guides – zamknout vodítka, se kterými nemůžete nyní pohybovat 
• Clear All – vymaže všechna vodítka 
• Save as Default – uloží aktuální nastavení jako předdefinované 
• Snap accuracy – citlivost přichytávání: můžete zadat jednu ze tří hodnot Must be close (musí být těsné), 

Normal (normální) nebo Can be distant (může být vzdálené). 
 
Podobně můžete nastavit i vlastnosti mřížky. Příkazem View > Gride > Show Gride zapínáte a vypínáte 

zobrazování mřížky. Pomocí View > Gride > Snap to gride zapnete přimykání k mřížce. Poslední příkaz 
View > Gride > Edit Gride otevře okno pro nastavení vlastností mřížky. Můžete zde zadat: 
• barvu mřížky, zobrazování nebo přichytávání k mřížce podobně jako v případě vodítek 
• ve dvou textových polích můžete zadat rozměr mřížky v obrazových bodech (pixelech): 

 

 

• podobně jako u vodítek můžete i u mřížky nastavit citlivost přichytávání. Navíc je zde možnost nastavit 
volbu Always Snap – vždy přichytávat. V tomto případě se budou všechny objekty zarovnávat polohou i 
velikostí na mřížku. 
 
Vedle možností přichytávání a zarovnávání na vodítka nebo podle mřížky, poskytuje Flash i možnost 

přichytávání přímo k hranicím objektů. Tuto možnost zapnete příkazem View > Snap to Object. 
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Jak vidíte na předchozím obrázku, jakmile se při tažení nového tvaru přiblížíte k hranici existujícího ob-
jektu, přichytí se referenční bod k této hranici, a pokud se budete s kurzorem pohybovat v dostatečné blíz-
kosti, bude referenční bod tuto hranici sledovat. 

Bezierovy křivky: nástroj Pero 
Nově se ve Flashi objevil nástroj pro kreslení bezierových křivek, který je známý snad ve všech vekto-

rových a dokonce i některých bitmapových editorech. Práce s nástrojem Pen (pero) možná bude pro někoho 
zpočátku trochu komplikovaná, proto se na jeho použití podíváme podrobněji: 

 

Lomenou čáru nakreslíte velmi 
jednoduše: vyberte nástroj Pen 
z panelu nástrojů a klepněte na místo, 
kde bude první bod lomené čáry. 
Uvolněte tlačítko myši a klepněte na 
další vrchol a postupně na další. 
Pokud byste se přiblížili k některému 
ze stávajících bodů, objevilo by se 
u symbolu pera malé kolečko na 
znamení, že zde je možné vytvořenou 
křivku uzavřít. 

 

 

Hladkou křivku nakreslíte tímto 
postupem: klepněte na první bod 
křivky. umístěte kurzor na druhý bod 
a se stisknutým tlačítkem myši 
vytáhněte čáru ve směru tečny ke 
křivce v tomto místě. Směr úsečky 
definuje směr tečny a délka úsečky 
definuje křivost. Čím delší úsečka, tím 
plošší křivka, čím kratší úsečka, tím 
ostřejší vrchol. Jakmile jste s tečnou 
spokojeni, uvolněte tlačítko myši 
a přesuňte kurzor do dalšího bodu, 
kde celý postup zopakujte. 

Vytvořenou křivku je možné následně ještě tvarovat: 

 

Pokud přecházíte z koncového 
bodu a posunete kurzor pera 
k některému z existujících bodů, 
zobrazí se u něj malé kolečko 
naznačující, že zde je možné 
křivku uzavřít spojením koncového 
a vybraného bodu. Pokud je 
nastavena barva výplně, bude 
uzavřená křivka současně 
vyplněna barvou. 
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Pokud jste těsně před tím 
nepracovali s koncovým bodem 
křivky (tj. vybrali jste např.  již 
existující křivku) potom, jakmile se 
kurzorem se symbolem pera 
přiblížíte k některému z hladkých 
bodů křivky, zobrazí se u tohoto 
kurzoru malá ostrá šipka. 
Klepnete-li tímto kurzorem na bod 
křivky, změní se z hladkého bodu 
na ostrý vrchol bez společné tečny.  

 

 

Pokud se kurzorem přiblížíte 
k některé ZAKŘIVENÉ (ne přímé) 
části křivky, přidá se ke kurzoru 
malý symbol +. Tímto kurzorem 
můžete vložit do křivky nový hladký 
bod. Tvar křivky se při tom 
nezmění. 

 

 

Pokud se kurzorem přiblížíte 
k některému ostrému vrcholu, 
objeví se u něj symbol -. Když 
tímto kurzorem na vybraný bod 
klepnete, bude bod z křivky 
odstraněn a tvar křivky se 
přizpůsobí zbylým bodům. 

 
Pro úpravy křivek je možné použít i nástroj Subselected Tool (prázdná šipka nahoře v pamnelu nástro-

jů). Nástrojem klepnete na křivku, abyste ji označili, potom pokud se přiblížíte k některému z bodů na křiv-
ce, zobrazí se u kurzoru malý nevyplněný čtvereček.  

 

Klepnete-li na uzel křivky, zobrazí se tečny 
(pokud jde o hladký bod). Nyní můžete buďto bod 
přetáhnou na jiné místo, nebo můžete táhnout 
koncový bod tečny a tím upravovat tvar křivky. 
Nástrojem Subselect je vybrán jeden z bodů 
křivky. Tažením koncového bodu tečny 
upravujete sklon tečny a případně i křivost 
z jedné strany. 
Pokud budete chtít vytvořit uzel, do kterého bude 
vstupovat z jedné strany přímý úsek a na druhé 
straně bude křivkový úsek, přetáhněte polohovací 
bod tečny na straně přímého úseku do uzlu. 
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Pokud budete chtít zpětně převést kombinovaný (z jedné strany přímá část, z druhé strany křivková) ne-
bo ostrý vrchol (stýkají se v něm pouze dva přímé úseky) na hladký (z obou stran křivky) je nejlepší postu-
povat takto: 
• nástrojem Pen (pero) klepněte na uzel a případně ještě jednou, abyste ho odstranili.  
• Potom novým klepnutím na tento úsek křivky vložíte nový bod.  
• Konečně nástrojem Subselect Tool přemístíte bod do nové polohy a případně upravíte polohu tečen 

a poloměr křivosti. 
 
Poslední možností tvarovat křivky je nástroj Arrow (šipka). Použití tohoto nástroje ale není specifické 

pouze pro křivky vytvořené nástrojem pero, a proto si jeho použití ukážeme v jedné z dalších části, která 
bude věnována změnám tvaru objektů. 

Štětec 
Nástroj Brush (štětec) slouží k malování. Jeho síla spočívá v tom, že toto malování může být jednak na-

stavenou barvou, nebo barevným přechodem, ale také bitmapou (viz část o barvách). Další vynikající vlast-
ností štětce je možnost selektivního malování. Je možné nastavit po čem se má a po čem se nemá malovat 
(nastaví se při vybraném nástroji Brush v části Properties panelu nástrojů): 
Paint Normal maluj normálně): 
překryje všechny objekty.  
Vlevo je na obrázku naznačen 
pohyb štětce, vpravo výsledek. 

 
Paint Fills (maluj výplně): 
malováním překrýváte pouze 
výplně, nikoliv obrysové čáry. 

 
Paint Behind (maluj za): malování 
štětcemse nedotkne výplně ani 
obrysů. Malujete jakoby za 
existujícími objekty.  

 

 
Paint Selection (maluj ve výběru – horní obrázek): štětcem nanesete barvu pouze do aktuálního výběru. 
Paint Inside (maluj uvnitř): štětcem malujete pouze uvnitř výplně, ve které jste začali malovat. 
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Důležité také je, že malováním štětcem vytváříte vektorový objekt. Používám sice termín „malovat“, 
který se spíše vztahuje k bitmapovým obrázkům, ale skutečně jde o objekt zcela srovnatelný např. 
s obdélníkem.  

Tužka 
Narozdíl od nástroje pero, který kreslí matematicky definované křivky, slouží nástroj Pencil – tužka – ke 

kreslení od ruky. Tužkou můžete kreslit libovolné tvary. Další rozdíl oproti peru je ten, že i když nakreslíte 
uzavřenou křivku, nebude její obsah vyplněn výplní. Pokud budete chtít výplň vytvořit použijte nástroj kbe-
lík s barvou. 

Pro nástroj tužka můžete nastavit: 
• druh obrysové čaáry a její tloušťku v panelu Stroke; 
• barvu obrysové čáry v různých panelech – Stroke, Colors, Mixer; 
• mód kreslení. 
 

U poslední volby se pozastavím. Na panelu nástrojů najdete při výběru nástroje Pencil (tužka) v části 
Options tlačítko Pencil Mode. Stiskněte na něm tlačítko myši a můžete vybrat mód kreslení z těchto nabí-
dek:  

 

Straighten (přímý) – kreslená čára bude sestávat z přímých úseků. 
Smooth (hladký) – roztřesená čára kreslená podle ruky bude vyhlazena. 
Ink (inkoust, stopa) – čára bude odpovídat skutečné stopě, kterou tužka při volném 
kreslení od ruky zanechá. 

 Na obrázku je ukázka použití jednotlivých módů kreslení tužkou: 
Ink Smooth Straighten  

 

Pokud budete chtít kreslit pravidelné objekty 
(kružnice, obdélníky, lomené čáry...) můžete 
použít vedle nastavení kreslicího módu 
Straighten také přichytávání k mřížce. 
Stejně tak může přinést výsledky i příkaz View 
> Snap to Object (nebo stejnojmenné tlačítko 
v pruhu základních příkazů). 
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Guma 
Nástroj guma neslouží pouze pro odstraňování nepohodlných a nepotřebných částí kresby, je možné ho 

použít i pro aktivní vytváření objektů. Je to dáno řadou nastavení, která jsou pro tento nástroj k dispozici. 
Podívejte se na popis u panelu nástrojů, zde si ukážeme pouze příklady gumování v různých módech, které 
nastavíte po výběru nástroje Eraser (guma) v části Options panelu nástrojů : 

 

Erase Normal (normální gumování): to, co 
gumou přejedete bude skutečně 
vygumováno. 
(Vlevo je zobrazeno gumování, vpravo je 
výsledek.) 

  

Erase Fills (gumovat výplně): při tomto 
nastavení se gumuje pouze výplň, obrysové 
křivky zůstávají nedotčeny. 

  

Erase Lines (gumovat čáry): při tomto 
nastavení se naopak vygumují všechny 
dotčené části linek, výplně zůstanou beze 
změny. 

  
Erase Selected Fills (gumovat vybrané výplně, obrázek nahoře): gumuje pouze výplně, které jsou součástí 
výběru. Vše, co je mimo výběr, zůstane gumováním nedotčeno. 
Erase Inside (gumovat uvnitř, dolní obrázek): gumuje pouze výplň, na které jste začali gumovat. Ostatní 
výplně oddělených částí zůstanou beze změny. 

   

Výběr 
Nástroj pro provádění výběrů je velmi důležitým nástrojem. Přidáte-li k tomu poněkud odlišné chování 

ve srovnání s jinými výběrovými nástroji grafických aplikací, bude dobře mu věnovat trochu místa. Nástroj 
pro výběr – Arrow, šipka – najdete na panelu nástrojů hned vlevo nahoře. 
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Nástroj šipka (Arrow) pro provádění výběrů můžete použít několika způsoby, základní jsou klepnutí 
a tažení. Tažením vyberete všechny objekty nebo jejich části, které jsou v taženém obdélníku zahrnuty. 

  

Na obrázku je proveden výběr, 
který zasahuje části tří objektů. 
Po dokončení výběru jsou 
vybrané části odlišně zbarveny. 

 
 

Označený výběr můžete 
tažením přemístit (obrázek 
vlevo) nebo výběrem barvy 
výplně případně obrysové křivky 
(nástroje kbelík s barvou – Paint 
Bucket – nebo lahvička inkoustu 
– Ink Bottle – přebarvit. Není 
nutné nástroje přímo na výběr 
použít, postačuje nástroj vybrat 
a změnit nastavení barev. Pro 
přebarvení můžete použít 
i panel Mixer. 

 

Pokud chcete výběr udržet pohromadě i pro další operace, máte několik 
možností: buďto ho přenést do další nově vytvořené vrstvy, nebo z něj 
vytvořit skupinu příkazem Modify > Group. V tomto případě se kolem 
skupiny vykreslí tenký rámeček signalizující, že jde o seskupené 
objekty. Chování takovéto skupiny se odlišuje od chování ostatních 
objektů (viz další kapitola o základech vytváření animací). Poklepáním 
na seskupené objekty skupinu opět rozložíte na její jednotlivé části 
(nebo příkazem Modify > Ungroup). Blíže se následujícím problémem 
zabýváme v další kapitole. 

Pojďme zpět k dalším technikám výběru. Objekt můžete vybrat klepnutím nebo poklepáním: 

  

V ukázce jsou nakresleny dva objekty, nejprve 
obdélník a potom elipsa, která obdélník částečně 
překrývá. Klepnutím nástrojem Arrow (šipka) na výplň 
obdélníka vyberete pouze tuto výplň a můžete s ní dále 
pracovat, přebarvit ji nástrojem Paint Bucket (kbelík 
barvy), posunout ji, upravit její rozměr apod. Všimněte 
si ale dobře, že nakreslená elipsa „vykousla“ část 
výplně – objekty, které kreslíte neleží nad sebou, ale 
jsou umístěny v jedné úrovni a ořezávají se! 

Obdobně bychom mohli vybrat i obrysovou křivku 
a jako objekt ji umístit na jiné místo. Pokud ale na 
obrys obdélníka klepnete pouze jednou, vyberete 
pouze jeden z úseků obrysu (obrázek vlevo). Abyste 
vybrali celý obrys (respektive část po vykrojení elipsou) 
musíte na obrysovou křivku poklepat (obrázek vpravo). 
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Dokud pracujete s výběrem, můžete ho položit kamkoliv na plochu jeviště a nedojde k interakci 
s ostatními objekty. Jakmile ale výběr odznačíte (např. klepnutím nástrojem Arrow mimo výběr), aktuální 
výběr se definitivně umístí, překryje a odstraní části objektů pod sebou. Podívejte se na následující obrázek, 
kde v horní řadě je několikrát změněno umístění výběru a objekty na ploše zůstaly beze změny. V druhém 
řádku je situace, kdy byl výběr umístěn, odznačen, znovu vybrán, přemístěn atd. 

    
Jakmile výběr definitivně umístíte 
a odznačíte, ořízne objekty, které 
ležely původně na jeho novém 
stanovišti. Pokud výběr není 
odznačen, můžete ho posouvat 
libovolně.    

   Další důležitou technikou je výběr celého objektu, tj. výplň společně s obrysem. Pokud klepnete pouze 
na výplň, je označena samotná výplň a při přesunu bude oddělena od obrysu. Pokud chcete zachovat spojení 
výplň-obrys, musíte na výplň poklepat: 

    

První dva obrázky (světlé 
pozadí) ukazují situaci po 
jednom klepnutí nástrojem 
Arrow na elipsu. Byla 
vybrána pouze výplň a při 
přesunutí zůstal obrys na 
původním místě. 

  V druhém případě (tmavé pozadí) je poklepáním označena jak výplň, tak i obrys, a při přetažení se po-
sune obrys společně s výplní. Při přesunu bude vidět „díra“ po přemístěné elipse v tmavém obdélníku.  

Zatím jsme si ukázali pouze tu skutečnost, že se objekty a výběry vzájemně ořezávají. K tomuto dochází 
pokud jsou na styčné hraně v kontaktu různé objekty – výplň a obrysová hrana – a pokud je současně jejich 
barva různá. Pokud se setká výplň se stejnobarevnou výplní, nebo obrys se stejnobarevným obrysem, objek-
ty se naopak sloučí do jednoho. 

 
 

 
Podívejte se na předchozí obrázek: Dva jednoduché objekty – elipsa a obdélník – jsem nástrojem Arrow 

(šipka) rozdělil na poloviny a výběr posunul doprava. Po odznačení výběru (klepnutí nástrojem šipka mimo 
výběr) se stávající zbytek původního objektu a přesunutý výběr zkombinovaly dohromady. O tom, co z nich 
vzniklo se můžeme přesvědčit posunutím jednotlivých částí. Část výplně se spojila. protože má stejnou bar-
vu. Stejně tak se spojily na sebe navazující části obrysových křivek stejné barvy.. 
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Úpravy tvaru objektů 
Objekty, které nakreslíte můžete dále tvarovat. Ke změně tvaru použijete nástroje Arrow (šipka výběru), 

Subselect Tool (nástroj pro dílčí výběry) a nástroj Pen (pero). 

Změna velikosti, otáčení a zkosení 
Pro změnu velikosti objektu použijete nástroj Arrow. Klepněte na tento nástroj na panelu nástrojů, pro-

veďte výběr objektu, jehož velikost chcete upravovat a v dolní části Options panelu nástrojů se zobrazí tla-
čítko pro změnu velikosti: 

 
Vlevo je ukázka tlačítka Scale pro změnu 
velikosti vybraného objektu. Pokud nebudete 
pozorní a vyberete jedním klepnutím pouze 
výplň (druhý obrázek) dostanete výsledek 
podle třetího obrázku: zvětšena byla pouze 
výplň, obrys zůstal v původní velikosti. 
Při správném postupu – poklepání na objekt – 
se bude tažením za polohovací body zvětšovat 
výplň i obrys. 

Pokud chcete zachovat poměry stran, použijte tažení rohových polohovacích bodů. Při tažení některých 
bodů ve středech stran se bude objekt zvětšovat pouze lineárně v daném směru. Pro změny velikosti je 
vhodné používat i vodítka nebo mřížku. 

Druhé tlačítko v části Options nástroje Arrow (šipka) slouží k otáčení a zkosení výběru. Nejprve pro-
veďte výběr a potom klepněte na tlačítko Roptate (natočení): 

 

 
 

Vlevo je ukázka tlačítka Rotate pro otáčení 
případně zkosení vybraného objektu. Na 
druhém obrázku je situace po výběru 
(tentokrát pouze výplně) a začátku otáčení 
tažením za jeden z rohových bodů. Další 
obrázek představuje výsledek: otočena byla 
pouze výplň, obrys zůstal v původní poloze. 
Čtvrtý obrázek ukazuje zkosení tažením za 
jeden ze středových polohovacích bodů. 
V tomto případě je součástí výběru jak obrys, 
tak výplň. 

Změna tvaru 
Pro změnu tvaru je možné použít nástroje Arrow, Subselect Tools nebo nástroj Pen – každý z nich speci-

fickým způsobem. Podívejte se na stav kurzoru nástroje Arrow, pokud se s ním budete pomalu přibližovat 
k nevybranému objektu:  

    
V dostatečné vzdálenosti 
od objektu má kurzor 
standardní tvar – šipka 
s výběrovým 
obdélníčkem. 

Pokud najedete do 
objektu objeví se u šipky 
symbol oboustranné 
křížové šipky pro 
přemísťování. 

Pokud se právě dotknete 
hrany objektu, zobrazí se 
u kurzoru symbol křivky, 
což značí, že jste 
v elastickém módu. 

V tomto módu můžete 
tažením za okraj objekt 
tvarovat. 
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Pokud se kurzorem 
přiblížíte k ostrému 
vrcholu objeví se u něj 
symbol rožku. 

 

V tomto případě můžete 
změnit tvar přetažením 
ostrého vrcholu. Všimněte 
si, že v obou případech 
se upravuje jak výplň, tak 
i obrys. 

Dalším nástrojem pro úpravu tvaru je Pen (pero). Tomuto nástroji jsme věnovali samostatnou část, proto 
jenom poznámka: nástroj pero slouží k vytváření objektů z tzv. bezierových křivek. Můžete ho použít i ke 
tvarování již existujících objektů v tom smyslu, že jím lze měnit charakter uzlu – z hladkého na ostrý, je 
možné uzly odebírat a také přidávat.  

Posledním ze sady nástrojů pro úpravu tvaru je nástroj Subselect. Tento nástroj nám poskytuje možnost 
přístupu k jednotlivým uzlům obrysových křivek: 

 

Toto je základní podoba kurzoru Subselect (částečný výběr) mimo 
objekt. 

 
  

Tvar kurzoru se symbolem plného 
čtverečku, pokud se s ním 
přiblížíte ke hraně objektu.  

Klepnutím na stranu objektu se zobrazí 
vymezující obrysová křivka a jednotlivé 
uzly. 

Tažením za hranu můžete 
celý objekt přesunout. 

   
Přiblíží-li se kurzor k uzlu (vrcholu) 
řídicí křivky, objeví se u něj symbol 
prázdného čtverečku.   

Klepnutím v tomto případě označíte 
jeden z uzlů a můžete ho přetáhnou do 
jiné pozice. 

Takto bude vypadat upravený 
tvar objektu. 

Tyto postupy je možné dále kombinovat a komplikovat. Použijeme-li např. výběr (nástroj Arrow) a ná-
sledně nástroj Subselect, dostaneme následující výsledky: 

 
  

 

Nástroje Arrow (šipka) 
provedeme výběr 
zahrnující pouze část 
objektu. 

Vybraná část je odlišně 
zabarvena. 

Na hranu objektu klepněte 
tlačítkem Subselect –
v místě výběru se přidaly 
další obrysové body... 

které můžete tažením 
myši volně tvarovat. 
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Podobně můžete pracovat s výběrem a nástrojem Arrow s křivkami: 

  

Najeďte kurzorem na bod křivky, ve kterém se 
u kurzoru objeví symbol pravého úhlu. Tažením 
tohoto bodu můžete tvarovat čáru. 

  

Jako vrchol se rozpozná 
každý průsečík linek, 
případně i omezení 
výběrem. V tomto případě je 
vrchol tvořen průsečíkem 
elipsy a úsečky. Tažením je 
možné uzel posunout a tím 
tvarovat objekt. 

    
Výběrem označte část křivky.  Vrchol, který leží mimo výběr můžete přesouvat nástrojem Arrow do jiné 
polohy. Tažením hrany mezi vrcholy můžete upravovat tvar hrany.  

Pamatujte na to, že výběr je ve Flashi velmi silný nástroj. Slouží k definici části objektu například pro 
změnu barvy, ale v podstatě znamená také rozdělení objektu na dvě části – část, která je součástí výběru a na 
část mimo ni. Část výběru můžete přemisťovat, otáčet, zvětšovat... U části mimo výběr můžete tvarovat 
hrany a přemisťovat vrcholy: 

    
Použití různých technik pro úpravu tvaru objektu: výběrem je označena část objektu. Tento výběr je otočen 
o 180 stupňů. Nástrojem Arrow (šipka) je tvarována hrana objektu a v posledním obrázku je tažením upravena 
poloha vrcholových bodů obrysu. 

Jak vidíte, možností je velmi mnoho. Nejdůležitější je uvědomit si, že kreslené objekty se ve Flashi 
chovají poněkud odlišně od jiných aplikací. Jsou ve vzájemné interakci, ořezávají se a spojují dohromady. 
Pro transformace máte k dispozici různé nástroje, jejich kombinací můžete provést v podstatě libovolnou 
úpravu tvaru. 
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Text 
Nástroje pro práci s textem jsem nechal až jako poslední nástroj. Ve srovnání s jinými aplikacemi je zde 

jenom málo odlišností. Pro vložení textu použijte nástroj Text (má ikonu se symbolem A) z panelu pracov-
ních nástrojů. Klepněte nástrojem na plochu, kam chcete text napsat.  

 

Zobrazí se obdélníček s kolečkem v pravém horním rohu. Do tohoto 
obdélníčku můžete začít psát text. Šířka obdélníka se postupně 
zvětšuje tak, aby byl schopen pojmout napsaný text. 

 

Pokud chcete omezit šířku textového pole, přetáhnutím kolečka 
upravíte šířku textového pole. Vhodnými nástroji pro přesné určení 
potřebné šířky jsou vodítka nebo mřížka.   

 

Pokud je v pravém horním rohu textového pole čtvereček, zalamuje 
se text automaticky podle nastavení odstavců a zachovává 
nastavenou maximální šířku. 

Textové pole můžete přetažením myši umístit, můžete s ním otáčet, zkosit ho, měnit jeho velikost apod. 
Pro nastavení vlastních atributů textu máte k dispozici plovoucí panely Character (znak) a Paragraph (od-
stavec): 

 

V okně Character nastavujete vlastnosti znaků: 
- Font (písmo): můžete vybrat libovolné písmo, lze ale doporučit 

použití TrueType fontů, nejlépe běžně používaná písma (Arial, 
Times...) 

- velikost 
- vyznačovací řezy: kurzíva a nebo tučné písmo 
- lze nastavit barvu textu 
- prostrčení: proložení znaků 
- Kern (vyrovnání párů): pokud zaškrtnete toto políčko budou 

se vyrovnávat znaky, jako např. AV, které by měly být 
napsány blíže u sebe než např. dvojice MN. 

- svislé umístění: můžete nastavit horní nebo dolní index, nebo 
normální umístění 

 

Vlastnosti odstavců nastavíte v panelu Paragraph: 
- Align (zarovnání): máte na výběr zarovnání doleva, na střed, 

doprava a do bloku 
- dále můžete nastavit vzdálenost od levého a pravého okraje, 

odsazení prvního řádku a řádkový proklad. 

Jednotlivé hodnoty nastavujete buďto zapsáním příslušné číselné hodnoty do textového políčka nebo 
můžete použít táhlo. Pozor u některých hodnot je táhlo velmi citlivé a pokud vám trochu ujede ruka, zmizí 
vám text z obrazovky. Nápravu provedete nejlépe zadáním opravené hodnoty přímo do textového pole. 
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Vlastnosti textu (písmo, barvu, řez...) lze nastavit pro celý text před začátkem psaní nebo pro vybranou 
skupinu znaků. Klepněte na napsaný text nástrojem Text, a označte tažením vybranou skupinu znaků. Pro ně 
potom můžete z panelu Character vybrat jiné písmo  nebo pozměnit další vlastnosti.   

Texty mohou být ve Flashi v podstatě ve dvojí podobě – jako skutečný text (tj. zobrazovaný s použitím 
určitého druhu písma) nebo v podobě grafiky.  

 

Na první pohled nepoznáte rozdíl mezi 
objekty, oba vypadají jako pravé texty. 

 

Prvním rozdílem je akce po klepnutí nástrojem 
Text. Pokud jde skutečně o objekt Text, 
zobrazí se textový rámeček a umístí se 
textový kurzor mezi znaky a můžete text 
upravovat. Pokud byl ale text převeden na 
křivky pomocí Modify > Break Apart, není to již 
text, ale křivky ve tvaru textu. 

 

Nástrojem Arrow můžete jednotlivé znaky po 
převedení na grafiku (vektorovou) tvarovat 
podobně jako jsme si to ukázali v předchozí 
části s klasickými vektorovými objekty. To jestli 
ponecháte text v podobě textové nebo 
v podobě vektorů záležií na vás a na tom, co 
potřebujete s textem provádět. 

Některé další nástroje 
Na začátku jsem napsal, že Flash ve srovnání s jinými aplikacemi neoplývá nástroji pro práci s grafikou. 

Teď mi již nezbývá místo na to, abych se alespoň stručně zmínil o všech zbývajících. Proto pouze heslovitě: 
• Break Apart (rozdělit na části): příkazem Modify > Break Apart můžete převést některé objekty 

z jednoho stavu do jiného. Například můžete převést bitmapy na barvu, zrušit skupiny objektů a jak jsme 
si ukázali, převést text na křivky. 

• Convert Lines to Fills (převést čáry na výplně): jednoduše řečeno – rozdíl mezi čarou a výplní je v tom. 
že výplň má plošný rozměr, je tvořena uzavřenou hranicí a je vyplněna barvou. Čára má pouze délkový 
rozměr (je tvořena střednicí), nemá barevnou výplň, ale pouze barvu tahu a tloušťku zobrazované čáry. 
Ve Flashi nemůžete např. ani definovat proměnnou tloušťku čáry. Můžete ale použít náhradu, a tou je 
příkaz Modify > Shapes > Convert Lines to Fills. 

  
Zde je původní čára, která je tvořena střednicí 
a zadanou tloušťkou čáry. 

Po převodu vidíte, že střednice byla nahrazena 
plochou vymezenou obrysovou křivkou. 
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• Expand Fill (rozšiř výplň): tento příkaz (Modify > Shapes > Expand Fill) rozšíří na všechny strany 
označenou výplň o stejnou hodnotu. Tento efekt, i když se to na první pohled nezdá, má řadu použití. 
Jedná je např. vytvoření dutých, průhledných tvarů. Udělat třeba elipsu s průhledem uprostřed není pro-
blém, protože se jedná o velmi jednoduchý tvar. Pokusíte-li se ale udělat např. průhledné písmeno, nara-
zíte na problém. Řešením je právě použití příkazu Expand Fill: 

 

Nástrojem Text napíšeme znak. Je vhodné volit tučnější písmo, aby byl 
průzor dobře viditelný. Po napsání převedeme znak příkazem Modify > 
Break Apart na křivky.  
Po převedení je obrázek písmene A vybrán. Protože budu potřebovat ještě 
jednu kopii pro další postup, zkopíruji si tento objekt pomocí Ctrl+C a Ctrl+V 
a odsunu stranou. Znovu klepnutím vyberu rozbitý tvar písmene A použiji 
příkaz Modify > Shape > Expand Fill. V dialogovém okně zadáme 
požadovanou šířku rozšíření (např. 5 pxl., obrazových bodů) a dostaneme 
tento výsledek (viz obrázek vpravo dole):  

  

 

Obdobným způsobem mohu upravit kopii objektu, kterou jsem si v předchozím 
kroku schoval. Mohu opět pomocí příkazu Modify > Shape > Expand Fill upravit 
tloušťku tahů. Všimněte si, že v dialogu Expand Fill máte k dispozici dvě nastavení 
– Expand (tj. rozšíření směrem ven) a Inset (zúžení směrem dovnitř). 
Po potřebné úpravě, změním barvu tohoto objektu, je jedno jak, pouze potřebuji, 
aby byla jiná než u originálu. Nakonec přesuneme kopii znaku na rozšířené 
písmeno a vycentrujeme. 

 

Další kroky jsou tyto: 
- odznačíme výběr a tím jsem umístil objekt kopie na originál; 
- klepnutím znovu označím jinobarevnou kopii a klávesou Delete výběr odtraním. 

Pokud má objekt několik částí, musím označení a zrušení provést postupně pro 
každou část samostatně. 

- tímto postupem jsem odstranil objekt z místa kopie a tato místa jsou nyní 
průhledná; 

- abych eliminoval problémy s automatickým ořezáváním a slučováním objektů, 
označím klepnutím jednotlivé části zbytku znaku A (v mém případě jsou dvě – 
obrys a vnitřní trojúhelník), a příkazem Modify > Group vytvořím skupinu. Jak 
vidíte na sousedním obrázku, je vytvořená skupina opravdu průhledná a je přes 
ni vidět objekt ležící na stejné vrstvě. 

• Soften Fill Edges (změkčit okraje výplně): příkazem  Modify > Shape > Soften Fill Edge můžete změk-
čit, rozmáznout okraje výplně. Můžete tak např. vytvořit rozptýlený stín apod. Na obrázku vidíte dialog, 
ve kterém nastavíte šířku okraje a počet přechodových kroků. 
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Úvod do animací 
Než se pustíme do tvorby vlastní animace, je třeba si říci něco málo ze základů. Každá animace je ma-

lým podvodem, který vychází z určitých vlastností lidského oka a schopnosti vnímat vizuální změny. Oko 
zachytí změny ve scéně, kterou pozorujeme, předá je mozku, který tyto změny vyhodnotí. Při vyhodnoco-
vání změn je pozorovaná událost vzorkována, rozkládá se do jednotlivých obrazů. Uvědomte si, že pokud se 
díváte na otáčející se kolo s příčlemi, vidíte při určité rychlosti, že se příčle pohybují ve směru otáčení, při 
jiné rychlosti se zdá, že stojí na místě, a při jiné máte dokonce pocit, že se pohybují proti směru otáčení. 
Klasický film využívá toho, že promítá jednotlivá políčka rychleji, než stačíte postřehnout změnu. Stejně tak 
pracuje např. i monitor počítače, jehož snímková frekvence je ale několikrát vyšší než filmová. Jen na okraj 
– existuje i tzv. podprahové vnímání, které znamená, že mozek „vidí“ více, než je vám ochoten přímo sdělit. 
Tento efekt se kdysi zkoušel např. v reklamě, kdy takříkajíc na pozadí filmu běžela skrytá reklama, kterou 
člověk nevnímal, ale jeho mozek ano. Při této reklamě se používala pouze osamocená políčka filmu, která 
divák nestačil postřehnout, ale informace se přece jenom mozkem zachytila. Takovýto způsob sdělování in-
formací je plošně zakázán. 

Ve filmu se využívá ještě jednoho efektu, který se u lidského oka projevuje – reziduální efekt. Oko má 
určitou setrvačnost, dobu, po kterou si pamatuje obraz. Tato doba postačí k tomu, aby se filmové políčko za-
tmělo a původní snímek se nahradil novým snímkem. Filmový pás tak sice běží, ale vy vidíte každé políčko 
pouze na velmi krátký okamžik jako statický obrázek, pohyb filmového pásu tedy nevnímáte. U monitoru 
(nebo obrazovky televize) žádný filmový pás neběží, obrázek je statický sám o sobě, nepohybuje se. Pohy-
bující se paprsek ozařuje luminofory, které po dopadu paprsku vyzáří na kratičkou dobu světlo a pohasnou 
až do dalšího ozáření. Zde se sčítá setrvačnost luminoforu se setrvačností oka, proto při dostatečné obnovo-
vací snímkové frekvenci nevnímáme postupné zhasínání a rozsvěcení obrazovkových bodů, ale pouze 
klidný obraz.   

Animace jako taková má historické kořeny, ale největšího rozmachu dosáhla s nástupem filmu. Vyvinu-
la se celá řada technik, z nich nejjednodušší na představu je animace po celých obrázcích a nejznámější je 
asi animace s použitím průhledných fólií, tzv. Cell (filmová, celuloidová) animace. Při tomto způsobu práce 
je celý obrázek rozložen na jednotlivé části, některé z nich jsou nepohyblivé, jiné pohyblivé. Každá část je 
nakreslena na samostatné průhledné fólii. Potom stačí poskládat fólie na sebe a máte kompletní obrázek. 
Pohyblivé části se překreslují a nahrazují. Statická část obrázku zůstává a mění se pouze pohyblivé části. 

Celá animace se musí vyrovnat s jedním zásadním problémem: na kolik mezistupňů rozfázovat pohyb 
tak, aby byl maximálně plynulý, a současně aby příliš nenarostl počet obrázků, které je nutné vytvořit. Flash 
vám standardně nabídne počet 12 snímků za sekundu. Pro animace na webu 8 snímků.  

Budete-li chtít animovat např. 5vteřinovou ukázku, bude to znamenat 5 x 12 = 60 snímků. Proto se 
i v klasickém animovaném filmu se používá metoda tzv. keyframes (klíčové rámečky). V podstatě to zna-
menalo, že hlavní tvůrce vytvořil pouze zásadní obrázky, a mezipohyby dotvořil již tým kresličů. 
V počítačové technice místo týmu kreslířů nastupuje programové vybavení, které je schopno změny, které 
se odehrají mezi klíčovými rámečky, dotvořit samo. Může jít např. o pohyb některého objektu, o změnu tva-
ru, barvy, průhlednosti apod. 

Tímto postupem je možné zredukovat počet obrázků, které musí skutečně autor vytvořit, na minimum. 
Na druhé straně tím naroste náročnost na optimální rozvržení animace, aby bylo možné uvedený postup 
vhodně využít.  

Program Flash poskytuje obě možnosti vytváření animací – jak animaci typu frame-to-frame (rám-rám), 
tak animaci s generovanými mezistavy, tzv. tweened animaci (z anglického between – mezi). Některé ani-
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mace však pomocí mezistavů vytvořit nejde a je nutné použít klasickou cell animaci rám-rám, nebo kombi-
naci obou. 

 
Podívejte se na horní obrázek: jednotlivé snímky je možné vytvořit jako zcela samostatné obrázky 

a animaci pořídit snímek za snímkem, vhodné bude každé políčko vyskládat z několika vrstev. Na každé 
vrstvě může být část, která se mění, nebo část, která se nemění.  

V uvedeném případě by to byla vrstva HLAVA (jsou použity celkem dvě hlavy), vrstva RUCE (zde jsou 
tři varianty), vrstva TĚLO je pouze jedno tělo pro všechny obrázky) a NOHY (jsou dvě provedení). 
V případě obrázku na vrstvách je možné každou vrstvu upravovat samostatně.  

Program Flash poskytuje obě možnosti práce, ale má pro vás i něco navíc. 

 
Celá animace ukazuje průjezd auta zleva doprava. V takovém případě postačí ve Flashi zadat počáteční 

a koncový snímek (tzv. klíčové rámečky, keyframes) a o zbytek se již postará program, který zbývající ob-
rázky sám vygeneruje. Takovéto animaci se říká Motion Tweened (pohybová mezisnímková) animace. Tuto 
mezisnímkovou animaci bychom mohli použít i v předchozím případě např. pro animaci pohybu rukou pis-
tolníka. V obou ukázkách je samozřejmě použit velmi malý počet snímků, který by nemohl vytvořit dojem  
skutečného pohybu. Při snímkové frekvenci 12 fps (frame-per-second, snímků za vteřinu) by obě animace 
trvaly necelou polovinu vteřiny. Velmi jednoduše bychom si mohli pomoci např. zdvojením, nebo ztrojením 
snímků a tím animaci protáhnout. 

Jinou možností mezistavové animace je tzv. Shape Tweened (tvarová mezisnímková) animace, kdy pře-
chází jeden tvar do druhého: 
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I v tomto případě postačí ve Flashi zadat počátek a konec a všechny mezisnímky dopočítá počítač. 
 
Než se pustíme do vlastní animace, podívejme se na nástroje, které máme k dispozici a na některé zá-

kladní pojmy. 

Základní prvky animace 
Animace může být vytvořena několika na sebe navazujícími scénami. Každá scéna může být tvořena 

řadou postupně zobrazovaných rámečků (frames). Obsah těchto rámečků může být rozložen na jedné nebo 
několika vrstvách. Rámečky mohou být prázdné, častěji ale budou obsahovat obrázky, které mohou být jako 
statické vytvořeny uživatelem nebo vygenerovány z počátečního a koncového rámečku počítačem. 

Úmyslně se zde vyhýbám interaktivním animacím, kdy průběh provádění může řídit uživatel. 

Scéna 
Jednoduché animace budou obsahovat třeba jenom jednu scénu. Rozsáhlejší animace mohou mít ale 

scén několik. V našem případě bez interaktivního ovládání ze strany uživatele, se budou jednotlivé scény 
přehrávat postupně, jedna za druhou. Pořadí scén vidíte na panelu Scene, který vyvoláte příkaze Window > 
Panels > Scene. 

 

V tomto panelu je seznam scén animace. Pořadí přehrávání 
je dáno pořadím, v jakém jsou scény v tomto seznamu 
uvedeny. Pořadí scén můžete jednoduše změnit přetažením 
na jiné místo v seznamu. 
Na dolním pravém okraji jsou uvedena (zleva doprava) 
tlačítka: 
- Duplicate Scena: vytvoří kopii vybrané scény, jejíž obsah 

můžete následně upravovat. 
- Add Scene: přidá novou zatím prázdnou scénu, 

obsahující pouze jeden rámeček a jednu vrstvu. 
- Delete Scene: odstraní aktuálně označenou scénu. 

Standardně se scény vytvářejí s názvem Scene 1, Scene 2 atd. Je ale vhodné si kvůli orientaci scény 
označit smysluplnějšími názvy. Poklepejte na název scény a budete ho moci přepsat. 

Scénu nastavíte jako pracovní, tj. je zobrazena její časová osa obsahující přehled jednotlivých rámečků 
s členěním na vrstvy, klepnutím na název scény v panelu Scenes. Jinou možností je tlačítko na panelu časo-
vé osy: 
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Klepnutím na tlačítko 
Scenes u pravého 
okraje okna časové osy 
se zobrazí seznam 
existujících scén. 
Scéna, kterou označíte, 
se zobrazí. Název 
aktuálně vybrané scény 
je uveden vlevo pod 
titulkem okna, zde je to 
scéna s názvem 
vymizení.  

Pokud není časová osa zobrazena, použijte příkaz View > Timeline. 
Scéna obsahuje několik rámečků, které se jako políčka filmu přehrají za sebou. Výsledný obraz je dán 

průhledem rámečků všech vrstev pod sebou pro konkrétní postavení přehrávací hlavy, na výše uvedeném 
obrázku jsou dvě vrstvy: Layer 2 a Layer 1. 

Vrstvy 
Použití vrstev v programu Flash neslouží pouze k lepší organizaci práce. Bez vrstev byste nebyli schop-

ni vytvořit složitější animace. Jak jsme si uvedli již dříve, jednotlivé objekty, které jsou umístěny na jedné 
vrstvě se vzájemně ovlivňují – spojují se dohromady (pokud jsou stejné barvy) nebo se ořezávají (pokud 
jsou různobarevné). Použití objektů na různých vrstvách tento vliv zcela eliminuje. Navíc máte možnost za-
cházet s každým objektem zcela samostatně, můžete využívat např. průhlednost, která se projeví teprve při 
několikavrsvém uspořádání, používat masky vrstev apod. 

Než se podíváme na jednotlivá nastavení a práci s vrstvami, podívejme se na to, jak jsou vlastně objekty 
na vrstvách uspořádány. Každá vrstva je v podstatě tvořena základní vrstvou a jakousi krycí vrstvou. Na zá-
kladní vrstvě jsou objekty, které jste nakreslili, tj. např. obdélník s výplní, křivka kreslená perem apod. Tato 
základní vrstva, nebo též vrstva jeviště (stage layer), představuje vlastně pouze kreslicí plochu. Objekty, kte-
ré na ní leží, nemohou být zařazovány nad sebe, leží pouze v jediné úrovni a proto se nemohou překrývat. 
Objekt, který je na místo, jež zabírá jiný objekt, přesunut (nebo vytvořen) později, původní obraz překryje 
a buďto se spojí se stejnobarevným objektem původním, nebo původní objekt ořízne: 

  

V tomto případě mají oba objekty – 
původní i nově nakreslený obdélník – 
stejnou barvu a proto budou sloučeny 
dohromady do jednoho objektu. Totéž 
se stane pokud na existující objekt 
umístíte jiný objekt stejné barvy. Pozor 
– musíte rozlišovat mezi výplní 
a obrysem. Aby se objekty spojily, 
musí se dotýkat výplň výplně nebo 
linka linky a potom se spojí výplň 
s výplní nebo linka s linkou..  
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Pokud např. bude mít v tomto 
uvedeném případě obdélník 
definovanou obrysovou křivku, 
nedotýká se výplň výplně a místo 
spojení dojde k oříznutí elipsy. Nestačí 
ani to, že barva obrysu a výplně je 
stejná, nezapomeňte, že pracujeme 
s vektory! Jak vidíte na obrázku s 
posunutím, obrysová linka obdélníka 
způsobila, že objekty se nesloučily 
a původní elipsa byla oříznuta.  

  

Pokud by ale měla elipsa také obrys, 
a to ve stejné barvě jako nakreslený 
obdélník, došlo by ke spojení obrysů, 
což si můžeme názorně předvést na 
levém obrázku. 
Tím, že jsem ale obrys posunul, došlo 
nejprve k tomu, že se sloučily nyní 
sousedící výplně, a posunutý obrys 
rozdělil výplň na tři části – horní z nich 
jsem na pravém obrázku posunul. 
Druhá část ležící v eliptické části 
obrysové křivky je vybrána a má 
poněkud světlejší barvu. Zbývající část 
leží v obdélníkové části obrysové 
křivky. 

Tato alchymie probíhá pouze na jedné vrstvě, objekty ležící na různých vrstvách jsou zcela samostatné 
a mohou se vzájemně překrývat bez interakcí. Mezi objekty na různých vrstvách lze například definovat 
průhlednost: 

  

Na obrázku vlevo je u výplně 
obdélníka nastavena 50% 
průhlednost. Proto, pokud obdélník 
leží ve vyšší vrstvě, je pod ním vidět 
překrytá část elipsy na nižší vrstvě.  
Změníme-li pořadí vrstev tak, že 
obdélník bude ležet na nižší vrstvě, 
překryje neprůhledná elipsa zcela část 
obdélníka. Protože jsou ale oba 
objekty na různých vrstvách, můžete 
měnit jejich polohu aniž by došlo 
k oříznutí nebo sloučení. 

V každé vrstvě leží ještě nad touto úrovní jeviště ještě úroveň překryvná (Overlay Layer). V této úrovni, 
která je nerozdělitelně spjata s úrovní jeviště v rámci jedné vrstvy, leží objekty typu skupina, text, bitmapa 
nebo instance symbolu. Mezi objekty uvedených typů je možné definovat pořadí, tj. zařazovat je nad sebe, 
posouvat je apod. bez obav, že by se tyto objekty ořezávaly nebo spojovaly.  
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Na horních dvou obrázcích je situace na jedné 
vrstvě: je zde nakreslená elipsa a dvě importované 
bitmapy. Jak vidíte, lze měnit pořadí zobrazování 
obou bitmap i jejich umístění aniž by došlo 
k interakci mezi nimi nebo s elipsou na pozadí. Je 
to dáno tím, že elipsa leží na úrovni jeviště, obě 
bitmapy na překryvné úrovni, ale v rámci jediné 
vrstvy. 
Pokud obě bitmapy převedeme příkazem Modify > 
Break Apart, budou z překryvně úrovně přesunuty 
dolů na úroveň jeviště a potom se chovají jako 
každý jiný objekt této úrovně – jednotlivé objekty 
se ořezávají a slučují.    

Základní informace o jednotlivých vrstvách získáte z panelu časové osy. Pokud tento panel není zobra-
zen, použijte příkaz View > Timeline.  
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Na panelu časové osy je velké množství údajů. Především je panel rozdělen na dvě části: část seznamu 
vrstev a vlastní časovou osu – přehled rámů. V záhlaví je uveden název scény (zde implicitní Scene 1).  
Scénu, se kterou chcete pracovat, můžete vybrat ze seznamu, který je umístěn na horním okraji panelu vpra-
vo. 

K části rámů se dostaneme později, nyní se zaměříme na seznam vrstev. Na předchozím obrázku jsou 
zobrazeny celkem 4 vrstvy pojmenované Text, Reflektor, Efekty a Pozadí. Začnete-li pracovat na nové ani-
maci standardně se vytvoří jedna scéna a jedna vrstva pojmenovaná Layer 1. Vrstvu přejmenujete poklepá-
ním (tedy dvojitým klepnutím) na její název v panelu časové osy.  

Pro přidávání vrstev můžete použít tlačítko na dolním okraji vlevo (Insert Layer – přídat vrstvu). Pořadí 
vrstev lze změnit přetažením vrstvy v panelu na jiné místo, nahoru nebo dolů. Obrazy a akce na horních 
vrstvách překrývají obsah spodních vrstev. 

Existující vrstvu můžete snadno odstranit tak, že vrstvu označíte klepnutím a potom klepnete na ikonu 
odpadkového koše (Delete Layer – Odstranit vrstvu). 

Nahoře nad seznamem vrstev jsou uvedeny tři ikony: 
• ikona oka – Show/Hide All Layers (Zobrazit/Skrýt všechny vrstvy): klepnutím na ikonu přepínáte mezi 

zobrazením nebo skrytím všech vrstev. 
• ikona zámku – Lock/Unlock All Layers (Zamknout/Odemknout všechny vrstvy): pomocí tohoto tlačítka 

můžete uzamykat všechny vrstvy, tj. přepínat mezi povolením a zákazem uprav na vrstvě. 
• ikona čtverečku – Show All Layers as Outline (Zobrazit všechny vrstvy jako drátěný model): toto tla-

čítko dovoluje měnit mód zobrazování z plného zobrazení objektů na zobrazení pouze jejich obrysu, tj. 
zobrazení jako drátěný model. Toto zobrazení, které je průhledném, může pomoci v orientaci při velkém 
množství vzájemně se překrývajících vrstev s množstvím objektů. 
 
Panel časové osy ale poskytuje i možnost individuálního nastavení jednotlivých vrstev. Klepnete-li ve 

sloupci příslušné ikony v řádku některé vrstvy, můžete změnit každé z nastavení způsobem , který pro da-
nou vrstvu potřebujete: 

 
V předchozím obrázku je vrstva: 

• Text zobrazována, uzamčena pro úpravy a její objekty se zobrazují pouze obrysem 
• Reflektor – tato vrstva není zobrazena a má nastaveno uzamčení pro úpravy. Byla by zobrazena 

jako drátěný model 
• Efekty je aktivní, pracovní vrstva, je zobrazena v plném zobrazení objektů (čtvereček na pravém 

okraji seznamu je plný) a není zamčena pro úpravy. 
• Pozadí se zobrazuje, je uzamčeno a zobrazuje se plně. 

Pokud uvidíte u aktivní vrstvy symbol přeškrtnuté tužky, není možné na vrstvě z nějakého důvodu pro-
vádět změny. Důvodem může být uzamčení vrstvy zámkem nebo to, že aktuálně vybraná vrstva nemá povo-



Ú v o d  d o  a n i m a c í  

47 

leno zobrazování. Způsob zobrazení jako drátěný model nemá vliv na výsledné zobrazování hotové anima-
ce. Stejně tak ani vypnutí zobrazování neovlivní výsledek – obě nastavení se vztahují pouze k pracovnímu 
prostředí Flashe. 

Vlastnosti vrstev 
Pro jednotlivé vrstvy můžete otevřít dialogové okno vlastností vrstev. V tomto okně můžete vedle již 

zmiňovaných vlastností nastavit i některé další. Okno Layer Properties (vlastnosti vrstvy) otevřete pravým 
klepnutím na řádek vrstvy a výběrem příkazu Properties.  

 

V tomto dialogu můžete přímo změnit 
název vrstvy v editačním poli Name 
(jméno). 
Dvě zaškrtávací políčka Show (zobraz) 
a Lock (uzamkni) umožňují nastavit 
zobrazování vrstvy v pracovní ploše 
a její případné uzamčení pro provádění 
úprav. 
Přepínače Type (typ vrstvy) umožňují 
nastavit vrstvu jako jeden z pěti typů: 
- Normal: normální vrstva 
- Guide: řídicí vrstva 
- Guided: chování objektů na vrstvě je 
řízeno jinou řídicí vrstvou 

- Mask: vrstva tvoří masku pro jinou 
vrstvu 

- Masked: vrstva je maskována jinou 
vrstvou. 

Položka Outline Color umožňuje 
nastavit barvu, kterou se budou 
zobrazovat obrysy objektů v případě, že 
bude nastaven mód zobrazování pouze 
obrysy. 
View layer as Outline: objekty vrstvy se 
budou zobrazovat pouze obrysem ve 
tvaru drátěného modelu. 
Layer Height: nastaví výšku řádku 
vrstvy v seznamu vrstev. Můžete zvolit 
hodnotu od 100% do 300%. 

V tomto dialogovém okně jsme narazili na dva nové termíny Guide (řízení, vedení) a Mask (maska) 
v případě typů vrstev. Jejich použití si ukážeme na konkrétních příkladech, zde jenom stručné vysvětlení: 
můžete vytvořit vrstvu, ve které bude definována křivka, podle které se bude řídit pohyb objektů na další, 
tzv. Guided (řízené) vrstvě. Typ vrstvy Mask definuje vrstvu, která obsahuje masku pro jinou vrstvu. Může-
te si to představit tak, že vrstva typu Mask obsahuje průzory, kterými je vidět pouze část maskované vrstvy., 
vše ostatní z této vrstvy bude skryto. Pokud pracujete např. s programem CorelDRAW, znáte metodu 
oříznutí pomocí kontejneru (nebo vložení do kontejneru), kdy kontejner definuje oblast objektu, která je 
viditelná, vše ostatní je ukryto. Podobně např. ve Photoshopu existují masky vrstev. 

Přenášení objektů mezi vrstvami 
Málokdy se vám podaří si tak dobře rozvrhnout práci dopředu, že nebudete potřebovat přesunout objek-

ty mezi vrstvami. Pokud potřebujete některý z objektů přenést z jedné vrstvy do druhé, použijte známé pří-
kazy pro vyjmutí (Edit > Cut), kopírování (Edit > Copy) a vložení (Edit > Paste). K dispozici jsou 
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samozřejmě i známé klávesové zkratky Ctrl+X (vyjmutí), Ctrl+C (kopírování) a Ctrl+V (vložení). Pokud 
chcete vložit objekt do jiné vrstvy, než ze které jsou ho vyjmuli nebo kopírovali, postupujte takto: 
• označte objekt nebo objekty, které chcete umístit do jiné vrstvy. Pokud klepnete na objekt, automaticky 

se stane vrstva, ve které se objekt nachází, aktivní vrstvou a její řádek v číselné ose se podbarví; 
• pro označení objektů použijte techniky, které jsme si uváděli dříve v kapitole o manipulaci s objekty; 
• použijte klávesovou zkratku Ctrl+C (kopírování) nebo Ctrl+X (vyjmutí); 
• v číselné ose klepněte na název vrstvy, do které budete objekty vkládat a tato vrstva se nyní stane aktivní; 
• použijte klávesovou zkratku Ctrl+V, a objekt bude vložen do této vrstvy. 
• v případě, že použijete přímo vložení (Edit > Paste nebo Ctrl+V) bude objekt umístěn uprostřed jeviště; 
• pokud chcete zachovat pozici objektu jako v původním místě, použijte příkaz Edit > Paste in Place (vlo-

žit na místo, Ctrl+Shift+V). 
 
K dispozici ještě máte příkaz Edit > Paste Special, kterým otevřete společné dialogové okno Windows 

Vložit jinak. Z nabídek, které máte k dispozici, můžeme v tomto případě přenášení objektů použít možnost 
vložení jako bitmapový obrázek nebo jako objekt Flashe: 

 

použijete-li 
možnost Device 
Independent  
Graphic, vloží se 
objekt jako 
bitmapa (blíže viz 
část Práce 
s bitmapami). 
Možnost Flash 
Drawing 
odpovídá 
standardnímu 
vložení Ctrl+V. 

V případě vložení objektu jako bitmapy si uvědomte všechny rozdíly oproti vektorovým objektům (bit-
mapa je umístěna na překryvné úrovni vrstvy, můžete ji využít jako vzorek pro výplně...).    

Rámečky 
Zatímco vrstvy představují rozložení obsahu animace bez ohledu na časový průběh, ale spíše vzhledem 

k logickému členění na objekty a pro zajištění jejich viditelnosti, je rámeček časovým snímkem animace. 
Rámeček vlastně odpovídá políčku promítaného filmu. V každém časovém úseku vidíme vždy pouze rá-
mečky všech vrstev jedné scény, který odpovídá postavení přehrávací hlavy. 

Rámečky tvoří druhou část časové osy. Práce s rámečky je jednou z nejdůležitějších činností, kterou je 
třeba zvládnout pro vytvoření dobré animace. Existuje několik typů rámečků: prázdný, klíčový, statický... 
Flash 5 zavádí i nový pojem pro skupinu rámečků – Sprite. Tento pojem bychom mohli přeložit možná jako 
„přemístitelný symbol“, což znamená, že skupina rámečků se chová jako jeden prvek a je možné ji např. 
přesouvat jako celek v rámci časové osy tažením za některý z vnitřních rámečků.  
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Podívejte se na následující obrázek, který ukazuje základní typy rámečků a jejich skupin: 

 
Obrázek ukazuje základní prvky, se kterými se na časové ose budete setkávat. Vysvětlující popiska je 

zde uváděna jako název vrstvy. Především si všimněte přehrávací hlavy. Ta vyznačuje na časové ose pozici 
aktuálně aktivního rámečku. Tento rámeček se bude zobrazovat na jevišti na pracovní ploše. 

Na dolním okraji panelu si všimněte informačních políček, kde se uvádí číslo rámečku, a čas, který do 
této pozice uplyne od začátku přehrávání scény. Čas závisí na snímkové frekvenci přehrávání, která je uvá-
děna ve snímcích za vteřinu – fps (frame per second). V této ukázce je nastavena hodnota 12 fps, která je 
přednastavenou hodnotou pro běžnou animaci. 

Pro identifikaci rámečků se používají standardní symboly:  
• bez rámečku: šedé orámování políčka na časové ose – rámeček zde není definován; 
• prázdný rámeček: černé orámování jednoho bílého políčka – rámeček je prázdný, neobsahuje žádný ob-

jekt;  
• klíčový rámeček: v rámečku je černá tečka – klíčový rámeček obsahuje objekty, které jsou ve výchozí 

pozici, tvaru... pro následující akci; 
• sprite: orámovaná skupina několika rámečků – podle výplně plochy se rozlišuje několik druhů sprite, jak 

je uvedeno na obrázku v popisu vrstev. 
 
Nejjednodušší verzí sprite je statický sprite, skupina rámečků, která se mezi klíčovým a koncovým rá-

mečkem nemění. Tento sprite má na rozdíl od prázdných rámečků světle šedé podbarvení. 
Pokud je v rámci sprite definován pohyb objektu z jedné polohy do druhé, jde o sprite, který obsahuje 

pohybovou mezisnímkovou animaci (Motion Tween). První klíčový rámeček definuje výchozí pozici a kon-
cový klíčový rámeček určuje závěrečnou pozici objektu. Mezilehlé rámečku vypočítává počítač, proto je 
zde naznačena pouze čára se šipkou směrem ke koncovému rámečku. 
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Ve vrstvě Pohybový tween 1 obsahuje sprite správně definovaný pohybový tween, naopak ve vrstvě Po-
hybový tween 2 není definice správná a proto je čára čárkovaná. Důvodů, proč tomu tak je, může být více, 
podíváme se na některé z nich v ukázkách v závěru publikace. Jeden z nejčetnějších důvodů je ten, že pro 
vytvoření pohybového tweenu byly použity objekty úrovně jeviště a ne objekty překryvné úrovně (skupiny, 
symboly...). 

Sprite, který je tvořen pohybovým tweenem, má na rozdíl od statického sprite, světle fialové podbarve-
ní. 

Střední vrstva v mé ukázce představuje tvarový přechod mezi snímky – tvarový tween, Shape Tween. 
V tomto případě se mění postupně tvar objektu mezi počátečním a koncovým klíčovým rámečkem. Podobně 
jako u pohybového tweenu i zde je čarou naznačeno, že rámečky mezi oběma krajními polohami dopočítává 
počítač. Podbarvení tvarového tweenu je světle zelené, v tištěné knize pravděpodobně rozdíl nezpozorujete. 

Práce s rámečky 
Pokud začnete pracovat s novou animací, budete mít na počátku jednu vrstvu (Layer 1) a v ní jeden za-

tím prázdný rámeček. 

  
 Po vložení objektu se symbol prázdného rámečku změnil na klíčový rámeček. 
Pokud chcete vložit do časové osy další klíčový rámeček, stačí klepnout pravým tlačítkem na pozici rá-

mečku a z místní nabídky vybrat příkaz Insert Keyframe (vložit klíčový rámeček, F6) nebo Insert Blank 
Keyframe (vložit prázdný klíčový rámeček, F7). Můžete použít i příkazy Insert > Keyframe případně Insert 
> Blank Keyframe.  

Rozdíl mezi oběma způsoby vložení nového klíčového rámečku je v tom, že v prvním případě se do klí-
čového rámečku zkopíruje obsah předchozího klíčového rámečku a objekty budou vybrány. V druhém pří-
padě bude vytvořen zcela prázdný klíčový rámeček neobsahující žádný objekt. 

Pokud nový klíčový rámeček vkládáte ihned za předchozí definovaný rámeček, nestane se nic jiného, 
než že se v časové ose objeví nový klíčový rámeček na této pozici. Pokud ale definujete nový klíčový ráme-
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ček v oblasti bez rámečků, např. podle následujícího obrázku na pozici 5, zaplní se prázdné místo statickým 
spritem vytvořeným z předchozího klíčového rámečku, zde je to rámeček číslo 1.  

  
V ukázce vlevo byl použit příkaz pro vložení klíčového rámečku (Insert Keyframe) na pozici 5. Přehrá-

vací hlava se posunula na tuto pozici a na jevišti se tedy zobrazuje stav tohoto rámečku. Vidíte, že byl zko-
pírován obsah předchozího klíčového rámečku (číslo 1) a před tím prázdné rámečky 2-4 byly označeny jako 
statický sprite. Jsou tedy vytvořeny jako kopie klíčového rámečku č. 1. 

V druhém případě byl použit příkaz Insert Blank Keyframe, situace je naprosto stejná jako 
v předchozím případě s tou výjimkou, že do nového rámečku č. 5 se nepřenese obsah rámečku č. 1. Statický 
sprite 1-4 je ale i v tomto případě vytvořen. Pamatujte, že nemůžete mít v časové ose mezi rámečky prázdná 
místa bez rámečků. Můžete zde ale mít prázdné rámečky.  

Na začátku této části, která se týká rámečků, jsem říkal, že základní jednotkou je sprite, tj. skupina rá-
mečků určitých vlastností. Na uvedeném příkladě máte statický sprite zahrnující rámečky 1-4. Pokud 
posunete přehrávací hlavu na kterýkoliv z těchto rámečků, dostanete vždy stejný pohled na jeviště. Pokud 
změníte kterýkoliv z rámečků statického sprite, změní se všechny, nebo lépe řečeno měníte vždy klíčový, tj. 
první rámeček, i když přehrávací hlava stojí na jiném rámečku tohoto sprite. 

Do sprite můžete rámečky přidávat, stačí klepnout pravým tlačítkem myši kdekoliv uvnitř sprite 
a z místní nabídky vybrat příkaz Insert Frame (vložit rámeček). Sprite se pouze o jeden rámeček zvětší 
a všechny rámečky směrem doprava se o jedno políčku posunou. Podobně můžete příkazem Remove Frame 
vypustit kterýkoliv rámeček statického sprite. 
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Poslední rámeček (je jedno zda je to klíčový nebo koncový rámeček) můžete tažením myší přesunout na 

další pozici. Pokud jde o koncový rámeček sprite, „natáhne se“ sprite. Pokud přetahujete jeden samostatný 
klíčový rámeček, posune se na danou pozici a prostor mezi původní pozicí a novou polohou se vyplní 
prázdnými rámečky. 

Uvnitř časové osy můžete přetahovat koncové rámečky sprite pouze na úkor prázdných rámečků. Ne-
můžete koncový rámeček přetáhnout za již existující klíčový rámeček: 

  
 V tomto případě není možné přetáhnout koncový rámeček statického sprite dále než k pozici nejbližší-

ho klíčového rámečku. Pokud byste potřebovali sprite ještě natáhnout, musíte rámečky přidat příkazem In-
sert > Frame nebo shodným příkazem z místní nabídky. Chcete-li přidávat po jednom rámečku, klepněte 
např. na statický sprite pravým tlačítkem a tím označíte jeden rámeček. Příkazem Insert > Frame přidáte 
právě jeden rámeček. Pokud na sprite klepnete levým tlačítkem označí se celý sprite a příkazem Insert > 
Frame zdvojnásobíte počet rámečků sprite:  

 

Původní délka sprite byla 1-11, 
po přidání rámečků zahrnuje nyní 
sprite rámečky 1-22. 

Se sprite (ať již jde o statický nebo tween sprite) můžete pracovat jako s jedním objektem: klepnutím ho 
označíte a tažením můžete přesunout na jinou pozici. 

  
I v tomto případě budou uvolněné rámečky vlevo zaplněny prázdnými rámečky (tj. rámečky bez obsa-

hu). Naopak, jak vidíte, byl sprite přetažen i přes existující klíčové rámečky (na pozici 23). Tento rámeček 
je ztracen. 

S rámečky můžete pracovat i mezi vrstvami. Uchopte sprite na jedné vrstvě a přetáhněte ho na jiné mís-
to jiné vrstvy. Překryté stávající rámečky na cílové pozici budou ztraceny: 
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Na prvním obrázku vlevo je statický sprite, který přetahuji na novou pozici z druhé vrstvy do čtvrté 

vrstvy. Po umístění je sprite na původní pozici v druhé vrstvě nahrazen prázdnými rámečky a existující spri-
te ve čtvrté vrstvě je vloženým sprite rozdělen na dvě části. V obrázku vpravo jsem při tažení podržel stisk-
nutou klávesu Alt a tím jsem sprite z původního místa zkopíroval a ne odstranil. 

Možností, jak s rámečky pracovat, je ještě celá řada, můžete např. s klávesou Shift vybírat rámečky 
a sprite z různých vrstev, i v nesouvislých sekvencích atd. Takovéto úpravy ale mohou způsobit nekonzis-
tentnost celé animace a provádějte je proto opatrně. Na závěr ještě upozornění – samostatný rámeček se 
chová poněkud odlišně od sprite. Tažením koncového rámečku sprite měníte délku sprite, ale pokud táhnete 
samostatný rámeček, přesouváte ho na jiné místo. Vložení klíčového rámečku dovnitř pohybového tween 
sprite bude mít s největší pravděpodobností tragický následek pro celý tween, pokud to neděláte úmyslně, 
jak si dále ukážeme. 

Úprava zobrazení rámečků 
Na konec této části jsem nechal možnosti nastavení zobrazování rámečků.  

 

Na pravém okraji časové osy najdete malou ikonu. 
Klepnutím na ni rozvinete nabídku časové osy, 
která vám umožní zvolit vhodný režim zobrazování. 

 

První skupina nastavení se týká zobrazované šířky rámečků: 
- Tiny (drobný) – šířka rámečku bude nastavena jako velmi malá, toto nastavení 

se hodí pro rozsáhlé animace s dlouhými sekvencemi tween sprite. 
- Small (malé) 
- Normal (normální) – doporučeníhodné nastavení šířky rámečku 
- Medium (střední) 
- Large (široké) – šířka rámečku je velmi  široká 
Druhá skupina nastavení upravuje výšku řádků vrstev. V části zabývající se  
vrstvami jsme si ukázali, jak je možné v dialogovém okně Layer Properties 
nastavit individuálně výšku řádku pro jednu vrstvu. Příkaz Short zmenší výšku 
řádku všech vrstev, což může být vhodné při práci s velkým množstvím vrstev.   
Poslední tři příkazy upravují způsob zobrazování rámečků na ose: 
- Tinted Frame (vybarvené rámečky) – rámečky se zobrazují jako obdélníčky, 

a jsou podle svého obsahu podbarveny (statické sprite šedě, sprite 
pohybového tweenu fialově a  tvarového tweenu světle zeleně) 

- Preview (náhled) – v rámečku se zobrazí náhled pouze objektů; šířka 
rámečků se zvětší. 

- Preview in Context (plný náhled) – na rozdíl od předchozího se zobrazí 
celkový náhled jeviště. 
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Symboly a knihovny 

Symbol 
Vedle objektů, které v případě potřeby přímo vytvoříte kreslením, nabízí Flash použití tzv. symbolů. 

Jsou to objekty, které jsou určeny pro opakované používání, nebo objekty, které v sobě skrývají již předefi-
nované akce, a Flash nám jejich použití nabízí ve formě zástupného symbolu. 

Existují celkem tři druhy symbolů: grafické (Graphic), tlačítka (Buttons) a filmové klipy (Movie Clips). 
V této publikaci se pouze dotkneme možnosti vytvoření a použití grafických symbolů. 

Velkou výhodou použití symbolu je to, že na rozdíl od jiných objektů, je symbol v animaci uložen pouze 
jednou a na místě jeho použití se pouze vytvoří odkaz na něj. Tento postup práce se označuje jako vytvoření 
instance symbolu. Tímto způsobem je možné dosáhnout zmenšení velikosti animace, což zejména u animací 
pro web je více než žádoucí. Menší velikost souboru znamená rychlejší natažení. 

Movie Clip (filmový klip) – jde o samostatnou animaci, jejíž časová osa je zcela nezávislá na časové 
ose hlavní animace. Movie Clip můžete obsahovat v podstatě vše, co může obsahovat animace Flash. Po 
spuštění není tato animace závislá na animaci v rámci níž byla spuštěna a může tedy běžet i po ukončení 
hlavní animace. Použití Movie Clip je dobrá technika pro zpřehlednění hlavní animace, která by v podstatě 
mohla obsahovat pouze jeden rámeček se zavedením tohoto symbolu. 

Graphic (grafika) – obsahuje buďto jednotlivý statický obrázek nebo animaci. Na rozdíl od Movie Clip 
jsou zde ale určitá omezení, symbol typu Graphic nemůže být interaktivní, neobsahuje tlačítka a zvuky. Má 
svoji časovou osu, ale ta je podřízena časové ose hlavní animace. Tento symbol je ale možné začleňovat do 
dalších symbolů. 

Vytvoření grafického symbolu 
Pokud máte nakreslen nějaký tvar, a víte, že ho budete opakovaně používat, může být vhodné převést 

nakreslený objekt na symbol. Tento postup je jednoduchý, ale ne příliš praktický. Každý objekt musíte nej-
prve nakreslit a teprve potom ho příkazem Insert > Convert to Symbol převedete na symbol: 

 

Otevře se dialogové 
okno, ve kterém můžete 
zvolit typ chování 
(Behavior) nového 
symbolu a jeho jméno 
(Name). 

Tento postup je použitelný, ale může být pracný, a současně vzhledem k tomu, co jsme si říkali 
o výběrech objektů, i problematický v tom, že součástí výběru nemusí být všechny objekty, nebo naopak 
jsou do výběru, který konvertujete na symbol, zahrnuty i objekty jiné. Můžete si pomoci tímto postupem: 
• příkazem Insert > New Symbol otevřete již uvedené dialogové okno, ve které zadáte Graphic a napíšete 

vhodné jméno symbolu pro rychlou identifikaci; 
• po klepnutí na tlačítko OK se přepnete do samostatného editačního okna symbolu, ve kterém vám neza-

vazí žádné objekty, které aktuálně na jevišti jsou; 
• v editačním okně můžete symbol vytvořit za pomoci všech nástrojů, které poskytuje Flash pro vytváření 

objektů na jevišti. 
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Na následujícím obrázku si povšimněte, že v oblasti časové osy se zobrazil vedle názvu scény i název 
symbolu. Tento název je podbarven. Pokud jste s úpravami na této úrovni hotovi, postačí klepnout na název 
scény a vrátíte se do normálního editačního režimu animace.  

 

Na obrázku je vytvářený symbol 
s názvem Symbol 2. Pokud budete 
s úpravami hotovi, postačí klepnout na 
název Scene 1. 
  

Do editačního režimu symbolu se můžete přepnout i později, budete-li chtít třeba i dodatečně upravit 
vzhled nebo chování symbolu. Postupů, jak symbol editovat je celá řada, záleží i na tom, ze kterého místa 
editaci spouštíte. Například postačí poklepat na instanci symbolu na jevišti, nebo využít místní nabídky 
symbolu (otevře se po pravém klepnutí na symbol). Místní nabídka dává možnost volby ze tří způsobů edi-
tace: 
• Edit (editovat) – editace bude provedena ve vlastním editačním okně symbolu; 
• Edit in Place (editovat na místě) – symbol můžete upravovat přímo na jevišti; 
• Edit in New Window (editovat v novém okně) – pro editaci symbolu se vytvoří zcela samostatné okno. 

 

Na tomto obrázku nového editačního okna symbolu si 
především všimněte, že symbol má svoji vlastní časovou 
osu. 
I když vše vypadalo tak, že vytváříme symbol jako statický 
obrázek, není tomu tak. Symbol typu Graphic (grafika) 
může představovat samostatnou animaci, i když 
s některými omezeními.  
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Instance symbolu 
Po vytvoření je symbol umístěn v knihovně  – Library. Knihovnu můžete zobrazit příkazem Window >  

Library.  

 

Vytvořený symbol byl vložen do 
knihovny a je připraven pro další 
použití.  
V náhledovém okně se zobrazí jeho 
tvar (vlevo). Pokud je symbol 
animací, je v náhledovém okně 
připraveno i tlačítko pro spuštění 
této animace (obrázek vpravo). 

 
Použití symbolu z knihovny je velmi jednoduché: můžete přímo přetáhnout symbol z okna knihovny na 

plochu. Před tím však vyberte správnou vrstvu a nastavte pozici přehrávací hlavy na správný rámeček. Tím 
jste vytvořili instanci symbolu. Je třeba rozlišovat instanci a vlastní symbol. Instance je odkazem na symbol, 
může mít určitá vlastní nastavení odlišná od nastavení jiných instancí téhož symbolu. Změny, které provede-
te na symbolu, se promítnou do instancí. Můžete proto velmi jednoduše dosáhnout téže změny v rámci ani-
mace.  

Naopak změnami instance není dotčen vlastní symbol. Pokud chcete editovat symbol, udělejte to 
z knihovny. Zamýšlíte-li editovat instanci, použijte k tomu příkaz Modify > Transform a vyberte některý 
z příkazů, který vyhovuje vašim potřebám: 

 

- Scale (změna velkosti): zobrazí se polohovací body a jejich 
tažením můžete zvětšovat nebo zmenšovat instanci symbolu. 
Tažením středních polohovacích bodů měníte velikost lineárně 
v daném směru (změna není proporcionální); 

- Rotate (natočení): pomocí polohovacích prvků. Umožňuje i 
zkosení. 

- Scale and Rotate (změna velikosti a natočení): zadáním 
číselných údajů v dialogovém okně; 

- Rotate 90° CW (natočení o 90° ve směru hodinových ručiček) 
- Rotate 90° CCW (natočení o 90° proti směru hodinových ručiček) 
- Flip Vertical/Horizontal (zrcadlení svisle/vodorovně) 
- Remove Transform (odstraň transformaci) – návrat k původnímu 

nastavení podle symbolu, z něhož je instance vytvořena; 
- Edit center (uprav střed symbolu) 

Zde provedené transformace se nedotknou vlastního symbolu. Stejně tak i změna chování instance pro-
vedená v panelu Instance, který aktualizujete klepnutím na instanci symbolu. Pokud není panel Instance vi-
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ditelný, otevřete ho buďto z místní nabídky instance symbolu (po pravém klepnutí) nebo pomocí Window > 
Panels > Instance. V panelu Instance můžete změnit typ a případné provádění animace: 

 

Můžete změnit chování v rozbalovacím seznamu Behavior. 
Způsob přehrávání případné animace můžete nastavit na: 
- Play Once (přehrát jednou) 
- Loop (přehrávat ve smyčce) 
- Single Frame (jeden obrázek) 
V textovém poli First můžete zadat, který rámeček z animace 
grafického symbolu se bude přehrávat jako první (nebo také 
třeba jako jediný). 

Možnost nastavení Single Frame vám dává i jednoduchou možnost použít symbol typu Graphic jako zá-
sobník tématicky společných statických obrázků, které uložíte do rámečků 1, 2, 3... tohoto symbolu.  
V konkrétní instanci potom zvolíte, který rámeček chcete v konkrétním případě zobrazovat. V následující 
části, týkající se práce s knihovnou symbolů, si ukážeme jiné, vhodnější uspořádání symbolů.   

Knihovna 
Symboly se ukládají při svém vytvoření do knihovny – Library. Knihovnu můžete zobrazit příkazem 

Window > Library. Knihovna představuje vlastně zásobník určitých typů objektů pro opakované použití. Do 
knihovny, kterou obsahuje automaticky každá animace vytvořená ve Flashi, se ukládají: 
• symboly, které ve Flashi vytvoříte; 
• bitmapy, které importujete; 
• importované zvuky; 
• a také písma, které v animaci použijete. 

 

V panelu Library najdete seznam všech v dané animaci použitých nebo 
jenom vytvořených symbolů, ale i ostatních importovaných objektů. 
V náhledovém poli si můžete prohlédnout ukázku symbolu, případně 
i spustit animaci. 

 

Pod tlačítkem Options u pravého 
horního rohu panelu se skrývá 
poměrně velmi rozsáhlá nabídka 
příkazů: 
- New Symbol (vytvořit nový 

symbol) 
- New Folder (možnost 

vytvoření složky v knihovně pro 
lepší uspořádání objektů) 

- Rename (změna jména 
položky) 

- Move to New Folder (vytvoří 
novou složku a přesune do ní 
označenou položky) 

- Properties (zobrazí vlastnosti 
vybrané položky) 

- ...  
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Použití složek pro členění obsahu knihovny je velmi vhodné, pokud máte skutečně značné množství 
symbolů, importovaných bitmap, zvuků apod.  

 
 Panel Library ale neslouží pouze jako zásobník, ze kterého můžete vytáhnout potřebný objekt. poskytu-

je i základní informace o těchto objektech.  Podívejte se na horní obrázek, kde vidíte roztažený panel Libra-
ry. V jednotlivých polích jsou uvedeny informace jako Kind (druh objektu: bitmapa, grafický symbol, 
složka...), Use Count (počet použití), Linkage (propojení: zdrojem může být např. webová adresa) a Date 
Modified (datum změny). Zobrazení aktuálního stavu použití objektů dosáhnete příkazem Update Use 
Count Now z nabídky Options (je vpravo nahoře v okně Library). Všimněte si také vytvořené složky Bit-
mapy, do které jsou přesunuty importované bitmapové obrázky. Poklepáním složku sbalíte a opětovně i roz-
balíte. 

Je třeba se zmínit ještě o jedné skutečnosti: jako knihovna symbolů může sloužit kterýkoliv ze souborů 
*.fla, který obsahuje knihovnu symbolů. Tak si můžete symboly z kterékoliv animace ve Flashi zpřístupnit 
v právě zpracovávané animaci.  

 

Na obrázku je knihovna aktuální animace 
a její symboly, vedle je knihovna ze 
souboru Circular Motion.fla (je to 
ukázkový soubor z Flashe). Tuto 
knihovnu jsme otevřel příkazem File > 
Open As Library. 
Symboly, ale i jiné dostupné prvky, 
můžete buďto přetáhnout do knihovny 
vaší animace, nebo je přímo umístit na 
jeviště. 
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Jednoduché animace 
V této poslední části si ukážeme jednoduché příklady animací. 

Nastavení základních parametrů 
Příkazem Modify > Movie otevřete okno vlastností animace, Movie Properties.  

 

-  

V okně Movie Properties můžete nastavit: 
• Frame Rate (snímková frekvence): rychlost, jakou se bude animace přehrávat udaná v rámečcích za vte-

řinu (frame per second, fps). Přednastavená je hodnota 12 fps, pro promítání na webu můžete tuto hodno-
tu snížit až na 8 fps. V časové ose je potom třeba sledovat, jak dlouho každá akce, kterou navrhnete, 
potrvá. Každý pohyb by měl být rozfázován tak, aby působil přirozeně. Pokud upravíte snímkovou frek-
venci, bude pravděpodobně zapotřebí upravit i počet snímků. Čas, po který bude akce probíhat, je počet 
rámečků x snímková frekvence. 

• Dimension (rozměr): udává se v obrazových bodech, pixelech. Při návrhu animace počítejte i s uživateli, 
kteří pracují na 15” monitorech s rozlišením 640 x 480 bodů. Pokud upravujete rozměr podle vytvořené 
animace, můžete klepnout na tlačítko Contents, pokud budte chtít nastavit rozměr podle aktuálního na-
stavení tiskárny a papíru, klepněte na Printer. 

• Background Color (barva podkladu): standardně je nastavena bílá barva podkladu jeviště. Můžete si ale 
nastavit barvu dle potřeby. 

• Ruler Units (jednotka pravítka): pro nastavení pravítka. K dispozici máte jednotku: obrazové body (pi-
xely, doporučuji si na tuto jednotku zvyknout), mm, palce apod. Podle tohoto nastavení se budou zobra-
zovat také údaje na panelu Info. 

• Save Default (uložit jako standardní): právě nastavené hodnoty budou uloženy jako přednastavené 
a standardně se použijí při vytváření nové animace.    

Cell animace 
Tato animace typu rám-rám (frame-to-frame) sestává z jednotlivých rámečků, které obsahují postupné 

fáze pohybu. Vytvoříme jednoduchou animaci, při které se bude uprostřed jeviště pomalu otáčet čtverec. 
později si ještě tuto animaci ukážeme jednou za použití jiného postupu. Vše, co budeme potřebovat, je jedi-
ný objekt, čtverec, který budeme postupně otáčet a vkládat do jednotlivých rámečků. 



M a c r o m e d i a  F L A S H  5  

60 

 
V prvním kroku vybereme nástroj pro kreslení čtverce. V panelu Stroke zvolíme vlastnosti obrysové čá-

ry a v panelu Fill vlastnosti výplně. Abychom nakreslili čtverec, můžeme si zapnout mřížku (příkazem View 
> Gride > Show Gride a zapnout přichytávání k ní příkazem View > Gride > Snap to Gride), nebo použít 
vodítka vytažená z pravítek. Já použiji pouze vytažení obdélníka se zapnutým přimykáním k objektům 
(View > Snap to Objects). Při tažení obdélníka potom stačí sledovat malé kolečko u kurzoru, pokud se zvět-
ší, kreslím pod úhle 45°. 

Jak vidíte na obrázku, ani jsem se nezabýval žádnou vrstvou, ani rámečkem. První vrstva je automaticky 
vytvořena stejně jako první rámeček. Na začátku je symbol rámečku prázdný, protože jsem ještě nevytvořil 
žádný objekt. Nakreslený čtverec se automaticky umístí do tohoto prvního rámečku a současně se 
v symbolu rámečku na číselné ose objeví černá tečka na znamení, že jde o klíčový rámeček.. 

 

Dále je třeba vložit další rámeček. Využiji toho, že při vložení nového klíčového rámečku se do tohoto 
rámečku přenese i objekt z rámečku předchozího. Klepněte pravým tlačítkem na pozici druhého rámečku 
v časové ose a z místní nabídky vyberte Insert Keyframe. 
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Nyní přejdu zpět na jeviště, kde je připravená kopie čtverce. Čtverec je vybraný (pokud jsme někde na 
jevišti neklepl kurzorem). Proto ho mohu hned poněkud pootočit. Označím nástroj Arrow pro výběr 
a klepnut dole v panelu nástrojů na tlačítko Rotate. 

 
 Po natočení čtverečku mohu pokračovat dalším krokem – vytvořit další klíčový rámeček, natočit čtve-

reček... Protože jde o čtverec, postačí mi natočení o 45°. Dál se vzhledem ke středové symetrii bude vzhled  
otáčeného čtverce opakovat. Pootočení o 45° jsem provedl v 6 krocích, v rámečcích 1-6. Rámeček 7 by měl 
obsahovat totéž zobrazení jako rámeček 5 překlopený vzhledem k vodorovné ose, rámeček 8 jako překlope-
ný rámeček 4... až rámeček 11 by měl odpovídat rámečku 1. 

Pro kopírování mohu použít buď místní nabídku – prvým tlačítkem klepnu na rámeček číslo 5, z místní 
nabídky vyberu Copy Frames, pravým tlačítkem klepnu na rám 7 a vyberu Paste Frames. Překlopení (objekt 
je vybrán) provedu příkazem Modify > Transform > Flip Horizontal. 

Mohu ale celou akci provést i pomocí přetažení rámečku myší – klepněte na rámeček č. 4 a přetáhněte 
ho se stisknutou klávesou Alt na místo rámečku 8, a proveďte překlopení. Podobně bych mohl pokračovat 
s dalšími rámečky jeden po druhém. Naštěstí má Flash v zásobě nástroj pro ulehčení práce: potřebuji ještě 
přenést rám 2 na místo 10 a rám 3 na místo 9. Označím oba rámečky 2 a 3 a přetáhnu je na pozice 9 a 10 se 
stisknutou klávesou Alt (tím jsem je zkopíroval na nové místo). Pořadí rámečků je ale obrácené. Oba rá-
mečky na pozici 9 a 10 jsou stále označené, proto na ně klepnu pravým tlačítkem a z místní nabídky vyberu 
příkaz Reverse Frame (otočit pořadí rámečků).  
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  Takto vypadá první ukončená fáze naší mini animace. 11 rámečků představuje otočení čtverce o 180°. 

Na časové ose si můžete všimnout změněného vzhledu – z nabídky časové osy (otevřete ji klepnutím na tla-
čítko zcela na pravém okraji pruhu čísel rámečků na panelu časové osy) jsme vybral nastavení Medium.  

Nyní by stačilo překopírovat mezilehlé rámečky 1-10 na pozici 12-21, protože druhá polovina pohybu je 
antimetrická a nemusíme tedy měnit pořadí rámečků. 

Dříve než to ale provedeme, bylo by dobré prohlédnout si, co jsme vlastně vytvořili. Nejjednodušší pro-
hlídka je tažením přehrávací hlavy. Uchopte symbol přehrávací hlavy a pomalu ho táhněte od rámečku 1 až 
po rámeček 11. Na jevišti se vám budou postupně zobrazovat jednotlivé rámečky a můžete odhalit větší ne-
přesnost. Tažení můžete o kousek vrátit, pohybovat s hlavou třeba jenom po několika rámečcích, abyste si 
dobře prohlédli změny vzhledu. 

Celou animaci můžete spustit příkazem Control > Play. Animace se spustí z aktuální pozice přehrávací 
hlavy a proběhne do konce animace. Jinou možnost poskytuje příkazem Control > Test Movie (nebo Test 
Scene, což je v našem případě totéž). Ukázka animace proběhne v samostatném okně a probíhá ve smyčce. 
Jakmile chcete předvádění ukončit, zavřete toto okno. 

Při prohlížení asi zjistíme, že pootáčení rámečků nebylo zcela rovnoměrné a otáčení čtverce je místy tr-
hané, někdy se čtverec pozastaví. Naštěstí nám Flash nabízí nástroj na prohlížení několika snímků najednou, 
jakoby to byla průhledná fólie. 

 

Na dolním okraji časové osy je umístěno pět tlačítek. 
První z nich slouží k vycentrování aktuálního 
rámečku. Nás zajímá skupina čtyř následujících. 
Jedná se o nástroj Onion Skin (cibulové slupky).   
Postupně zleva jsou to tlačítka: 
- Onion Skin 
- Onion Skin Outlines 
- Edit Multiple Frames 
- Modify Onion Markers 

Nástroj Onion Skin zapíná zvláštní režim zobrazování, kdy se na jevišti současně zobrazí několik po so-
bě jdoucích rámečků. Toto zobrazení vám dovolí upravit polohu objektů tak, aby pohyb byl rovnoměrný 
apod. 

• Onion Skin: tímto tlačítkem zapnete mód zobrazení, kdy objek-
ty na aktuálně vybraném rámečku jsou zobrazeny se zvýrazně-
nými okraji i výplněmi. Rámečky před a za tímto rámečkem 
jsou tím více průhledné, čím jsou dále od vybraného rámečku 
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• Onion Skin Outlines: rámečky se zobrazí ve vrstvě pouze ob-
rysem, aktuálně nastavený rámeček jako zvýrazněný. 

 
• Edit Multiple Frames: toto tlačítko zapne možnost editace 

buďto objektů na více rámečcích současně, nebo vám bude na-
bízet jednotlivé rámečky pro provedení úpravy, např. natočení, 
postupně jeden za druhým. Na tomto zobrazení je také dobře vi-
dět nerovnoměrnost natočení čtverců v jednotlivých rámečcích. 

 
• Modify Onion Markers: pod tímto tlačítkem se skrývá nabídka úprav nastavení značek vymezujících 

rámečky, které se zobrazí ve výše uvedených režimech. Můžete zvolit počet 2, 5 nebo všechny. Dále je 
k dispozici nabídka Always Show Markers (vždy zobrazovat interval). Poslední možností je Anchor 
Onion (ukotvit interval). Při zapnuté této možnosti se nebude interval  rámečků, které se současně zob-
razují, přesouvat podle aktuální pozice rámečku. Jako výhodnější se mi jeví pracovat přímo tažením 
myší s hranicemi intervalu rámečků (viz obrázek dole):    

 
Po prohlédnutí obrázků můžeme jednotlivé rámečky upravit a podle potřeby je ještě zkopírovat a tím ce-

lou animaci prodloužit. 

Tween Motion 
V předchozí části uvedený způsob animace je velmi náročný na přesnost, je pracný a zdlouhavý. Naštěs-

tí jsou ve Flashi postupy, které umožňují řešit případy typu: objekt se přesune z jedné polohy do druhé, ob-
jekt se otočí, objekt změní barvu, objekt změní tvar  apod.  

Jedná se o případy mezisnímkové animace, kdy je třeba pouze určit dva klíčové rámečky a o interpolaci 
mezi nimi se již postará program samotný. Takovéto animace se označují jako Tween. Pokud je výsledkem 
animace pohyb objektu, otáčení, změna velikosti nebo barvy, označuje se taková animace jak Tweened Mo-
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tion anmace, tedy pohybová mezisnímková animace, pohybový tween. Pokud jde o přechod z jednoho tvaru 
do druhého, používá se označení Tweened Shape animace, tvarová mezisnímková animace, tvarový tween.  

Jednou z nezbytných podmínek pro úspěšné provedení mezisnímkových animací je to, že objektem 
animace nemůže být objekt úrovně jeviště. Musí to být objekt překryvné úrovně, tj. např. symbol, text, bit-
mapa nebo skupina objektů (objekty seskupené příkazem Modify > Group). Pro mezisnímkovou tween 
animaci nemůžete tedy přímo použít nakreslený objekt. 

Tween Motion je jeden z případů, kdy se objekt přesouvá z jednoho místa na druhé, mění svoji velikost 
apod. Vše si ukážeme opět na jednoduchém příkladu koule, která se má přesunout z jedné strany jeviště na 
druhou.  

V prvním kroku vytvoříme novou prázdnou animaci (příkazem File > New) a případně upravíme její 
vlastnosti (Modify > Motion). Dále nakreslíme kružnici a vyplníme ji přechodem. 

 

Z panelu Fill vybereme v seznamu položku Radial Gradient. 
Přetažením obou jezdců změníme počáteční a koncovou 
barvu:  

 

Ve středu gradientu je nyní světlá barva, která znázorňuje odlesk světla a přechází do krajů do tmavé 
barvy. Nástrojem Paint Bucket klepneme na nakreslenou kouli a ještě upravíme gradient: 

   
Klepněte na nástroj Paint Bucket (kbelík s barvou) a v části Options panelu nástrojů na tlačítko zcela 

dole vpravo – Transform Fill (upravit výplň). Nyní kurzorem klepněte na výplň koule a uvidíte pomocnou 
kružnici se třemi polohovacími body. Tyto body slouží pro (viz obrázek nahoře): 
• natočení gradientu 
• zvýšení nebo snížení prahu (výplň hrany) 
• změnu tvaru z kruhového na eliptický. 

Polohu středu barevného přechodu upravíte přetažením středního polohovacího bodu. 
Jakmile jste s tvarem, barevností... koule spokojeni, přistoupíme k vytvoření objektu, se kterým můžeme 

navrhnout pohybovou mezisnímkovou animaci (Motion Tween). Na začátku této části jsme si uvedli, že to 
mohou být mimo jiné symboly nebo seskupené objekty. Postupujte takto: 
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• poklepejte na obrázek, který jsme vytvořili, abychom označili jak výplň, tak i obrysovou čáru. 
• příkazem Modify > Group vytvoříte skupinu 

nebo 
• příkazem Insert > Convert to Symbol převedete tvar na symbol. 

 
Pro náš jednoduchý případ použiji variantu se skupinou. Na obrázku si všimněte, že kolem objektu se 

v případě výběru zobrazí tenký obdélník, který signalizuje, že se nejedná o běžný objekt úrovně jeviště. 
Podíváte-li se na časovou osu, vidíte zde první klíčový rámeček – to je ten, na kterém jsme nyní praco-

vali a ve kterém je vytvořena koule, kterou chceme kutálet po obrazovce. 
Pohybový tween vyžaduje dva klíčové rámečky: jeden počáteční a jeden koncový. Počáteční rámeček 

již máme, zbývá vytvořit klíčový koncový rámeček: 

 

• klepněte pravým tlačítkem na rámeček např. 10 na ča-
sové ose a z místní nabídky vyberte příkaz Insert Key-
frame. Tímto příkazem se vytvoří nový klíčový 
rámeček na uvedené pozici jako kopie aktuálního rá-
mečku a mezilehlé pozice 2-9 jsou vyplněny statický-
mi rámečky s klíčovým rámečkem číslo 1. Je tedy 
vytvořen statický sprite. 

• upravte počáteční pozici animovaného objektu v obou 
klíčových rámečcích. Pokud byste chtěli, aby se koule 
vkutálela na jeviště a vykutálela ven, označte objekt 
a přemístěte ho před levý okraj rámečku 1 a za pravý 
okraj jeviště u rámečku 10.  

• abyste mohli pracovat na konkrétním rámečku, musíte 
na něj přesunout přehrávací hlavu, Nejjednodušeji to 
provedete klepnutím na rámeček, se kterým chcete 
pracovat.  

 

Takto bude vypadat výchozí pozice obou klíčových rámečků (1 a 10) před nastavením pohybového 
tweenu: 
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Vlastní vytvoření mezisnímkového přechodu: 

 

- Klepněte pravým tlačítkem na v předchozích 
krocích vytvořený statický sprite (tj. na oblast 
rámečků mezi 1-10). 

- Z místní nabídky vyberte příkaz Create 
Motion Tween – a to je vše. 

Jak vidíte na obrázku, statický sprite byl 
nahrazen pohybovým mezisnímkovým sprite. 
Symbolizuje to šipka vycházející od rámu 1 
k rámu 10. 
Všimněte si také polohy koule, která odpovídá 
poloze přehrávací hlavy. Tato poloha 
animovaného objektu již byla vytvořena 
automaticky programem jako interpolace 
krajních  poloh objektu daných klíčovými 
rámečky. 
Pokud si budete chtít prohlédnout chování 
vytvořené animace, můžete použít přetažení 
přehrávací hlavy nebo příkaz Control > Play. 

Pro prohlédnutí můžeme použít i nástroj, který jsme si uvedli v minulé ukázce – Onion Skin: 

 

- klepněte pod časovou osou na tlačítko Onion 
Skin; 

- tažením myši posuňte značky začátku a konce 
zobrazované oblasti na rámečky 1 a 10 (nebo 
použijte příkaz Onion All z nabídky tlačítka 
Modify Onion Markers – je to 5 tlačítko zleva 
pod časovou osou) 

- v mém případě jsem ještě zapnul volbu Edit 
Multiple Frames (4 tlačítko zleva pod časovou 
osou). V tomto zobrazení jasně vidíte, že 
existují pouze dva editovatovatelné objekty 
v krajních polohách tweenu. Mezilehlé polohy 
jsou zobrazeny průhledně a vytváří je počítač 
bez vašeho ovlivnění (i když za chvíli si 
ukážeme, jak toto tvrzení obejít). 

Je možné, že dodatečně zjistíte, že délka animace je nevhodná – ať již příliš dlouhá nebo krátká. Bylo by 
třeba do animace vložit rámečky nebo je ubrat. Není nic jednoduššího – klepněte na sprite pravým tlačítkem 
myši a z nabídky vyberte příkaz Insert Frame. Toto opakujte tolikrát, kolikrát bude zapotřebí. Můžete si také 
zkusit přetažení koncového řídicího rámečku: 
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• označte na časové ose koncový rámeček a tažením myši ho přesuňte třeba na pozici 15. Všimněte si, že 

mezi novou polohou tohoto rámečku a jeho původním místem se vytvořila skupina prázdných rámečků. 
Rovněž upozorňuji na to, že se změnila šipka, která procházela tweenem na čárkovanou čáru. Ta signali-
zuje, že něco není s tweenem v pořádku a animace nebude fungovat. Zde je nám příčina jasná – odstrani-
li jsme koncový klíčový rámeček. V jiném případě to bude nejčastěji pokus vytvořit pohybový tween 
založený na objektech úrovně jeviště, tedy ne na objektech typu symbol, skupina... 

• klepněte na sprite pohybového tweenu a tím ho celý označíte; 
• přetáhněte nyní celý sprite pohybového tweenu až k přesunutému klíčovému rámečku; 

 
• na obrázku vidíte, že se tween opět bezproblémově obnovil – místo přerušované čáry vidíte plnou šipku; 
• posledním krokem je přetažení úvodního klíčového rámečku doleva na původní pozici č. 1. Tímto posu-

nem se nic nenaruší, automaticky se doplní potřebné rámečky tweenu, sprite se pouze natáhne. 
Co by se stalo, pokud bychom v předchozím případě přidávání rámečků do sprite pohybového tweenu 

přidali místo normálního rámečku klíčový rámeček (Insert Keyframe)? Vložil by se nový klíčový rámeček 
s objektem, který by byl vygenerován z aktuální pozice animovaného objektu. Podíváte-li se na obrázek, vi-
díte, že se uvnitř sprite objevila značka klíčového rámečku (černá tečka). 

 
Tato skutečnost nám dává možnost upravit chování objektu uvnitř tweenu. Klepněte na právě vložený 

klíčový rámeček, abyste si zpřístupnili objekt pro úpravy. 
• Označte kouli nástrojem Arrow a klepněte dole na panelu nástrojů v části Options na tlačítko Scale. 
• Stiskněte klávesu Shift a můžete upravit tažením polohovacích bodů velikost koule. Klávesa Shift slouží 

ke změně velikosti ze středu původního objektu. 

 

Pro úpravy můžete použít i příkaz Modify > Transform a z nabídky si 
vybrat některou z možností úprav: 
- Scale: změna velikosti tažením myši 
- Rotate: natočení objektu tažením myši 
- Scale and Rotate: změna velikosti a natočení na základě číselného 

zadání v dialogovém okně 
- Rotate 90° CW/CCW: natočení o 90° ve směru/proti směru 

hodinových ručiček 
- Flip Vertical/Horizontal: zrcadlení objektu svisle/vodorovně 
- Remove Transfor: zruší provedené transformace 
- Edit centr: upraví tažením myši polohu středu objektu 
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Takto bude vypadat výsledek naší práce v režimu Onion Skin: 

 
Jsou ještě nějaké jiné možnosti úpravy této animace? Především se podíváme na panel Frame. Klepněte 

pravým tlačítkem na časové ose na sprite pohybového tweenu a z místní nabídky vyberte položku Frame. 
Tím otevřete následující panel: 

 

Zde můžete nastavit: 
- Label: popiska, která se objeví i v časové ose a pomáhá při 

orientaci a určení tweenu; 
- Tweening: možnost výběru způsobu přechodu – Motion 

(phybový tween), Shape (tvarový tween), None (bez 
tweenu); 

- Scale: pokud se uvnitř tweenu změnila velikost objektu, 
potvrdíte, že tuto změnu chcete animovat; 

- Easing: urychlení, změny mezi klíčovými rámečky nebudou 
pravidelné, ale budou se urychlovat nebo zpomalovat; 

- Rotate: umožňuje natáčení objektu mezi krajními pozicemi, 
můžete nastavit None (žádná), Auto (automatciká mezi 
oběma krajními polohami), CW (ve směru hodinových 
ručiček) a CCW (proti směru). V obou dvou posledních 
případech můžete ještě zadat počet otočení v poli times; 

- Orient to Path: objekt se bude pohybovat podél cesty 
zadané v tzv. řídicí vrstvě (viz další ukázka); 

- Synchronize: pokud je pohybový tween vytvořen jako 
grafický symbol a počet rámečků joho animace neodpovídá 
prostoru, který je mu vyčleněn v hlavní animaci, můžete zde 
nastavit, že se má synchronizovat začátek tweenu s halvní 
animací 

- Snap: pokud je definována řídicí vrstva bude se objekt při 
pohybu přichytávat k řídicí křivce. 
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Podívejte se např. na změnu animace po nastavení hodnoty Easing (urychlení): 

 

Nastavením hodnoty Easing na 
kladnou hodnotu se zhustí obrázky 
u koncového rámečku tweenu. 
Výsledný dojem tedy bude, že se 
koule z rychlého pohybu bude 
postupně zpomalovat. 
Zadáním záporné hodnoty 
dosáhnete obráceného efektu – 
pohyb koule se bude postupně 
zrychlovat. 

Některé efekty nelze provádět na seskupených objektech a vyžaduje se práce s instancí symbolu. Abyste 
převedli objekt na symbol postupujte takto: 
• označte objekt, který chcete převést na symbol. V mém případě si nejprve vytvořím kopii objektu koule, 

a umístím ji do nově vytvořené vrstvy. Vrstvu přidám jednoduše klepnutím na tlačítko Insert New Layer 
vlevo dole na panelu časové osy: 

 

Je vytvořena nová vrstva 
a všimněte si, že byly 
vloženy i prázdné 
rámečky na současnou 
délku animace. 
Upozorňuji i na popisku 
„koule“, kterou můžete 
vidět u sprite tweenu na 
vrstvě Layer 1. To je 
popiska (Label), kterou 
jsme zadali v dialogu 
Frame. 

• při označeném objektu použijte klávesovou zkratku Ctrl+C pro zkopírování objektu do schránky (nebo 
příkaz Edit > Copy).  

• Klepněte na první rámeček vrstvy Layer 2, tím nastavíte přehrávací hlavu na tento rámeček a současně 
aktivujete vrstvu Layer 2 jako pracovní.  

• Klávesami Ctrl+V (nebo příkazem Edit > Paste) vložíte kopii objektu na jeviště.  
• Použijte příkaz Insert > Convert to Symbol: 

 

V dialogovém okně Symbol 
Properties zadejte název 
symbolu a typ chování 
(Behavior) – v našem případě to 
bude Graphic. 

• Klepněte na OK a symbol je vytvořen. Najdete ho nyní v knihovně Library (Window > Library) a jeho 
instance můžete umisťovat v rámci animace zcela libovolně pouhým přetažením z knihovny na jeviště. 
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Tím. že jsem do prvního rámečku umístil objekt, změnil se tento rámeček na klíčový a všechny za ním 
následující prázdné rámečky se změnily na statický sprite – obsahují pouze objekt přebíraný z prvního klí-
čového rámečku. Klepněte pravým tlačítkem na poslední rámeček tohoto sprite (podle obrázků je to ráme-
ček 13) a vyberte z místní nabídky příkaz Create Keyframe:  

 

 

Prohlédněte si rozdíl 
v časové ose před a po 
provedení uvedené akce: 
Z koncového rámečku 
statického sprite se stal 
klíčový rámeček. Jak již 
víme bude obsahovat kopii 
objektů z předchozího 
klíčového rámečku.  

Budeme chtít vytvořit animaci, která postupně skryje obrázek koule. V rámečku 1 kouli zobrazíme 
a necháme ji postupně mizet, až v rámečku 13 zmizí zcela. 

Nastavíme proto vlastnosti objektů v obou klíčových rámečcích: 
• klepněte na první klíčový rámeček. Jako aktivní musí být nastavena vrstva Layer 2. Pro jistotu jsem vy-

pnul zobrazování vrstvy Layer 1, aby se mi obrázky nepletly dohromady (ve sloupečku oka je u vrstvy 
Layer 1 křížek a nikoliv tečka).; 

• klepnutím označte objekt koule (jde o instanci symbolu Koule 1); 
• pokud nemáte zobrazen panel Effects, klepněte na instanci symbolu Koule 1 pravým tlačítkem a z místní 

nabídky vyberte příkaz Panels > Effects; 

 

V tomto panelu můžete 
nastavit řadu efektů pro 
činnost tweenu. Já budu 
potřebovat nastavit 
průhlednost, proto použiji 
položku Alpha. 

• objekt v prvním rámečku bude plně neprůhledný, proto zde bude nastavena hodnota Alpha 100%; 
• po nastavení přejděte do rámečku č. 13; 
• obdobným postupem nastavte hodnotu Alpha objektu koule na 0%. 

Tím je provedeno základní nastavení klíčových rámečků pohybového tweenu, který tentokrát bude způ-
sobovat postupné „zmizení“ koule při animaci. Abychom si mohli prohlédnout celý efekt i na stránkách pu-
blikace, posunul jsem poněkud objekt v prvním a posledním rámečku. 
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Nyní je nutno pouze vytvořit již známým způsobem pohybový tween: 
• klepněte pravým tlačítkem na statický sprite (tj. někde mezi oba klíčové rámečky na vrstvě Layer 2); 
• z místní nabídky vyberte Create Motion Tween a vše je hotovo: 

 
 V zapnutém režimu Onion Skin dobře vidíte činnost tweenu, který jsme vytvořili – z prvního neprů-

hledného zobrazení objektu koule postupně mizí, až zmizí docela. 
I v tomto případě můžeme celou akci snadno modifikovat, např. vložením nového klíčového rámečku 

dovnitř sprite. potom nastavíme v panelu Effects Alpha prvního rámečku na 0%, hodnotu Alpha vnitřního 
rámečku na 100% a dostaneme takovýto výsledek: 

 

Pokud by objekty ve všech klíčových rámečcích 
byly umístěny v téže pozici na jevišti, postupně by 
se koule objevila a zmizela. V časové ose vidíte 
pozici všech tří klíčových rámečků na časové ose.  
Zobrazování vrstvy Layer 1 je vypnuto, aby obrázek 
nerušil.  
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Pohyb podél cesty 
V předchozích ukázkách jsem animoval pohyb po přímce – z jedné polohy objektu přímo do druhé. 

V řadě případů nám to ale nebude stačit. Vezměme si jako příklad situaci, kdy bych chtěl, aby se naše koule 
nevkutálela na obrazovku, ale aby tam spadla, odrazila se a vyskočila ven. 

Celý postup je následující: 
• nejprve si vytvoříme novou vrstvu. Klepněte na tlačítko přidat novou vrstvu (Insert New Layer) vlevo 

dole v panelu časové osy. Tuto novou vrstvu si pojmenujeme, třeba jako Odraz: poklepejte na standardně 
vložený název vrstvy a napište svůj název. 

• nastavte klepnutím první rámeček této vrstvy jako aktivní a z knihovny symbolů přetáhněte na jeviště 
symbol Koule1. Umístíme instanci symbolu mimo jeviště, protože budeme chtít, aby koule na začátku 
animace na obrazovce nebyla, ale aby se vynořila za okrajem. 

• jako v předchozím případě se vytvořil statický sprite na celou délku animace. Klepněte pravým tlačítkem 
na poslední rámeček (č. 13) a vyberte Insert Keyframe. Postup je zatím stejný jako v předchozích přípa-
dech, a takový je výsledek: 

 

Na obrázku je stav posledního 
pravého klíčového rámečku na 
vrstvě Odraz. 
Spodní vrstvy nejsou vidět, 
protože je vypnuto jejich 
zobrazování. 

• v dalším kroku přidáme řídicí vrstvu pohybu: při označené vrstvě Odraz klepněte na tlačítko Add Guide 
Layer vlevo dole na panelu časové osy: 

 

Tlačítko pro,přidání řídicí vrstvy je umístěno vlevo dole pod 
seznamem vrstev na panelu časové osy. 
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Situace po 
přidání řídicí 
vrstvy 
k vrstvě 
Odraz.  

• na obrázku si všimněte, že vrstva Odraz je mírně posunuta vpravo a vyjadřuje tak spojení s vrstvou 
Guide; 

• pokud by nebyla vrstva Guide označena, označte ji klepnutím na její název; 
• nástrojem tužka (Pencil) nakreslete na tuto vrstvu křivku, podél níž se bude objekt pohybovat; 

 

Nakreslenou čáru nástrojem 
Pencil můžete upravit 
kombinací libovolných 
nástrojů, přidáváním uzlů atd. 
do podoby, která vám bude 
vyhovovat. 

 

Pro tvarování jsem použil 
nástroj Pen (pero) pro 
odstraněné uzlů a nástroj 
Subselect Tool pro úpravu 
křivostí křivky a polohy uzlů.  

• v dalším kroku pravým tlačítkem klepněte na statický sprite vrstvy Odraz, tj. někde mezi rámečky 1-13. 
Z místní nabídky vyberte Create Motion Tween. 

• pokud není zobrazeno okno Frame, použijte příkaz Modify > Frame:  

 

v panelu zaškrtněte políčka: Orient to Path a Snap. 
Protože budeme tuto animaci ještě upravovat, zaškrtněte 
i políčko Scale. 
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• po tomto nastavení klepněte ve vrstvě Odraz na první klíčový rámeček č. 1 a umístěte symbol koule na 
počátek řídicí křivky. Totéž proveďte se závěrečným rámečkem č. 13 celého tweenu: 

 

Při umísťování se objekt koule 
přimyká k vodicí křivce. Pokud by 
tomu tak nebylo, podívejte se na 
nastavení v panelu Frame, zda je 
zaškrtnuto políčko Orient to Path 
a Snap. 

• no a to je v zásadě vše. Prohlédneme si ještě vytvořené dílo pomocí Onion Skin: 

 

Pro vylepšení 
celkového pohybu 
by bylo ještě 
možné použít 
nastavení Easing 
v panelu Frame, 
případně i jiné 
efekty.. 

Tuto animaci můžeme ještě dotvořit tak, aby koule skočila ze zadu proti nám, a roztáhla se po celé obra-
zovce. To znamená, že musíme použít efekt změny velikost i změny Alfa kanálu průhlednosti. 

Celý postup můžeme upravit do následujících kroků: 
• použijeme jako základ již vytvořenou animaci a pouze upravíme řídicí křivku. Klepněte na vrstvu Guide 

a nástrojem Subselect Tool upravte uzly křivky tak, aby se koule objevila asi uprostřed horního okraje 
obrazovky, skočila dolů a její pohyb skončil přibližně uprostřed jeviště. 

• dále upravíme velikosti počátečního a koncového symbolu. Počáteční symbol v rámečku č. 1 vrstvy Od-
raz zmenšíme a naopak symbol v poslední klíčovém rámečku tohoto tweenu zvětšíme tak. až přesáhne 
celé jeviště. 

• nejprve klepněte na rámeček 1 vrstvy Odraz, označte objekt koule a příkazem Modivy > Transform > 
Scale zobrazíte polohovací body, kterými můžete upravit velikost objektu. podobně postupujte při úpravě 
objektu v rámečku 13 této vrstvy. 

• zkontrolujte, zda jsou oba objekty v klíčových rámečcích na správných místech řídicí křivky; 
• poslední úpravou je nastavení průhlednosti. Klepněte na rámeček 13 (poslední klíčový rámeček pohybo-

vého tweenu, který upravujeme). Pokud není viditelný panel Effect, otevřete ho například příkazem 
Window > Panels > Effect. V panelu vyberte efekt Alpha a nastavte velmi nízkou hodnotu, to znamená, 
že koule bude téměř průhledná. A to je vše. 
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Výsledek úprav si můžete prohlédnout v režimu Onion Skin: 

 
Řídicí křivka ve výsledné animaci nebude vidět, a jinak vše vypadá asi tak, jak jsme si představovali (v 

ukázce je zapnuta viditelnost všech vrstev, které jsme připravili): 
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Maska 
Vedle vrstvy obsahující křivku, která dokáže řídit pohyb objektu ve sdružené vrstvě, můžete použít 

i vrstvu s maskou. Jako zadání si připravíme efekt s baterkou osvětlující nápis. Budeme chtít, aby se na ob-
razovce objevil potemnělý nápis, na něj zasvítil reflektor, který nápis přejede zleva doprava. 

Celý postup je na základě již nabytých znalostí snadný: 
• nejprve vytvoříme v prázdné animaci vrstvu s nápisem; 

 

Nástrojem Text napište nápis. 
Doporučuji zvolit spíše robustní 
písmo, já jsem použil Arial Black. 
Jako barvu textu zvolte (na panelu 
Character) nějakou světlejší barvu, já 
mám azurovou. Kolem textu vidíte 
textový rámeček. do kterého se text 
umisťuje. Pro nastavení velikosti 
písma můžete použít buďto přímo 
nastavení písma v panelu Character, 
nebo můžete velikost upravit 
nástrojem Arrow s nastavenou volbou 
Scale, tak jako u jiných grafických 
objektů. 

• nápis je zatím uložen v prvním rámečku této vrstvy (pojmenoval jsem ji Nápis). Klepněte pravým tlačít-
kem na rámeček, do kterého chcete animaci rozšířit, např. na rámeček 20, a zvolte Insert Frame. Tím jste 
vytvořili statický sprite obsahující první klíčový rámeček a dalších 19 statických rámečků. 

• k této vrstvě přidáme další, která bude obsahovat jednoduchý pohybový tween: použijte tlačítko Insert 
New Layer a novou vrstvu, která se objeví nad vrstvou Nápis, přejmenujte na Maska. 

• připomínám, že tato vrstva obsahuje 20 zatím prázdných rámečků: 

 

Takto vypadá náš polotovar: vytvořený 
text a dvě vrstvy. 
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• ve vrstvě Maska vytvoříme jednoduchý pohybový tween. Klepněte na první rámeček této vrstvy a před 
nápisem (ten je v jiné vrstvě) nakreslete přibližné kolečko nástrojem Circle. Je jedno jakou bude mít vý-
plň, já jsem zvolil tmavší barvu, ale barva skutečně nehraje roli. Jde jenom o to, abyste objekt dobře roz-
lišili od ostatních v průběhu vytváření. 

• jakmile máte vytvořen první rámeček, klepněte na sprite této vrstvy (tj. někde mezi rámečky 1-20) pra-
vým tlačítkem myši a z místní nabídky vyberte Create Motion Tween; 

• po tomto úkonu se zatím nic nestane, protože nám chybí koncový klíčový rámeček. Klepněte na poslední 
rámeček (20) pravým tlačítkem myši a zvolte příkaz Insert Keyframe. Trochu překvapující je, že se po 
vytvoření tohoto klíčového rámečku ihned aktualizoval pohybový tween, jak nasvědčuje plná šipka mezi 
počátečním a koncovým klíčovým rámečkem tohoto sprite. Vše je dáno postupem, kdy Flash správně 
předpokládal, že když chci vytvářet pohybový tween ze statického sprite, budu asi chtít použít i objekt 
v prvním rámečku jako symbol, a udělal to za mě. podívejte se do knihovny, že tomu tak skutečně je, že 
nám přibyl symbol bez našeho přičinění. Pokud by tomu tak nebylo, museli bychom postupovat podobně 
jako v předchozím: 

- na kolečko v rámečku 1 poklepejte nástrojem Arrow, tím jste ho vybrali, a pro další průběh práce 
z něj musíme udělat: 

- buďto skupinu (Modify > Group)  
- nebo ho převést na symbol (Insert > Convert to Symbol. 

• tak či tak, máme vytvořen jednoduchý pohybový tween. Zbývá jenom posunout kolečko v rámečku 20 
na pozici na konci textu: 
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Další kroky rozhodnou o výsledku: musíme převést vrstvu Maska na skutečnou masku, která bude za-
krývat a odkrývat to, co leží pod ní. Naštěstí je celý postup velmi jednoduchý: 
• klepněte na vrstvu Maska pravým tlačítkem a z místní nabídky vyberte položku Mask. 
• zobrazení se nyní rázem změnilo: 

 

Především se název vrstvy Nápis 
posunul vpravo jako symbol svázání 
s vyšší vrstvou Maska. 
V obou vrstvách – Maska i Nápis se 
objevila ikona zámečku na znamení, 
že vrstvy jsou uzamčeny proti 
úpravám. Můžete je samozřejmě 
odemknout, toto je varování, že 
můžete třeba posunutím jedné 
z vrstev narušit správné fungování 
apod. 
Přeškrtnutá tužka u aktivní vrstvy 
Maska říká, že i když je tato vrstva 
aktivní, nelze na ni provádět úpravy, 
protože je zamčená. 
Zásadní změna se ale projevila ve 
vlastním zobrazení – z nápisu nám 
zbyl pouze kousek, a to právě 
kousek, který je umístěn pod aktuální 
polohou kolečka ve vrstvě Maska. 
Zkuste si tažením přehrávací hlavy 
měnit polohu kolečka a bude se vám 
měnit i poloha viditelné části textu. 

K plné spokojenosti ještě celou minianimaci dopracujeme: 
• přidáme další vrstvu pomocí tlačítka Insert New Layer a přejmenujeme ji na Pozadí; 
• přetáhneme tuto vrstvu na poslední pozici v seznamu vrstev; 
• na tuto vrstvu nakreslíme velmi tmavý obdélník velikosti, která s dostatečným přesahem překryje text na 

vrstvě Nápis; 
• z vrstvy Nápis zkopíruji text a přidám ho do nové vrstvy Pozadí a mírně ho posunu (ponechám tím 

v obrázku malý stín); 
• nástrojem Text označím text ve vrstvě Pozadí a přiřadím mu tmavošedou barvu, jenom trochu odlišnou 

od barvy podkladového obdélníka. 
A je to vše! Podívejte se na výsledek: 

 

Na první pohled nic moc, že? 

 

Jakmile ale pohnete přehrávací hlavou, uvidíte 
okamžitě, o co jsme se snažili: pohybem masky se 
zobrazuje posouvající se, jakoby osvětlená část 
textu ve vrstvě Nápis, a protože leží výš než vrstva 
pozadí, ve finálním zobrazení ji překryje. 
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Shape Tween 
Jenom velmi rychle k ukázce, kterou jsme slíbil u první animace typu frame-to-frame, kde jsme otáčeli 

čtverec. Podívejte se, jak to lze provést velmi jednoduše pomocí tvarové mezisnímkové animace – Shape 
Tween. 

Postup lze popsat několika málo kroky: 
• v prázdné animaci nakreslete na vrstvě Layer 1 v prvním rámečku čtverec, lépe bude, pokud vypnete 

kresbu obrysu; 
• pokud není zobrazen panel Frame, zobrazte ho např. příkazem Window > Panels > Frame; 
• vyberte položku Shape ze seznamu Tween 
• klepněte pravým tlačítkem na pozici, ve který bude koncový rámeček tweenu, např. na pozici 20; 
• z místní nabídky vyberte Insert Keyframe pro vložení klíčového rámečku s automaticky zkopírovaným 

objektem – čtvercem – z prvního rámečku; 
• tento objekt je vybraný a proto můžete klepnout na nástroj Arrow a v částo Options panelu nástrojů na 

tlačítko Rotate; 
• tažením za polohovací body pootočte čtverec v rámečku 20; 
• a to je vše. Situace nyní vypadá takto: 

 

Jak na obrázku (v zobrazení 
Onion Skin) vidíte, čtverec se 
skutečně otáčí z jedné polohy do 
druhé.  
Tvarový mezisnímkový přechod 
by se ale spíše použil na jiné 
změny tvarů, než na tuto ukázku, 
kde by asi bylo výhodnější použít 
pohybový tween s definovaným 
směrem otáčení a počtem otoček. 
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Na závěr 
Export a publikování 
Hotovou animaci můžete uložit příkazem File > Save ve formátu *.fla, což je interní formát Flashe. Pro 

spouštění aplikace v prohlížeči Flash Player použijte příkaz File > Export Movie do formátu *.swf. Prohléd-
něte si nabídku exportních formátů a vyberte si případně jiný, v závislosti na prohlížeči, který chcete použít 
pro spouštění animace. Velmi rozsáhlé možnosti nabízí příkaz File > Publish Settings, ve kterém můžete na-
stavit velké množství parametrů pro začlenění animace např. do HTML kódu pro spouštění na webu apod. 
Tato problematika je ale již mimo rámec této publikace. 

Vybrané klávesové zkratky 
Příkaz Nabídka Klávesová zkratka Příkaz Nabídka Klávesová zkratka 
100% View | Magnification Ctrl+1 Lock Guides View | Guides Ctrl+Alt+; 
Add Shape Hint Modify | Transform Ctrl+Shift+H Movie Modify Ctrl+M 
Align Window | Panels Ctrl+K Movie Explorer Window Ctrl+Alt+M 
Align Center Text | Align Ctrl+Shift+C New File Ctrl+N 
Align Left Text | Align Ctrl+Shift+L New Symbol Insert Ctrl+F8 
Align Right Text | Align Ctrl+Shift+R Next View | Goto Page Down 
Antialias View  Ctrl+Alt+Shift+A Open File Ctrl+O 
Antialias Text View Ctrl+Alt+Shift+T Open as Library File Ctrl+Shift+O 
Blank Keyframe Insert F7 Outlines View Ctrl+Alt+Shift+O 
Bold Text | Style Ctrl+Shift+B Paragraph Window | Panels Ctrl+Shift+T 
Break Apart Modify  Ctrl+B Paste Edit Ctrl+V 
Bring Forward Modify | Arrange Ctrl+Up Paste Frames Edit Ctrl+Alt+V 
Bring to Front Modify | Arrange Ctrl+Shift+Up Paste In Place Edit Ctrl+Shift+V 
Character Window | Panels Ctrl+T Play Control Enter 
Clear Keyframe Insert Shift+F6 Previous View | Goto Page Up 
Clear Edit Backspace Print File Ctrl+P 
Convert to Symbol Insert F8 Quit File Ctrl+Q 
Copy Edit Ctrl+C Redo Edit Ctrl+Y 
Copy Frames Edit Ctrl+Alt+C Remove Frames Insert Shift+F5 
Cut Edit Ctrl+X Remove Transform Modify | Transform Ctrl+Shift+Z 
Cut Frames Edit Ctrl+Alt+X Reset Text | Tracking Ctrl+Alt+Up 
Default File | Publish Preview F12 Rewind Control Ctrl+Alt+R 
Deselect All Edit Ctrl+Shift+A Rulers View Ctrl+Alt+Shift+R 
Duplicate Edit Ctrl+D Save File Ctrl+S 
Edit Grid View | Grid Ctrl+Alt+G Save As File Ctrl+Shift+S 
Edit Guides View | Guides Ctrl+Alt+Shift+G Scale and Rotate Modify | Transform Ctrl+Alt+S 
Edit Symbols Edit Ctrl+E Select All Edit Ctrl+A 
Fast View Ctrl+Alt+Shift+F Show All View | Magnification Ctrl+3 
First View | Goto Home Show Frame View | Magnification Ctrl+2 
Frame Modify Ctrl+F Show Grid View | Grid Ctrl+´ 
Frame Window | Panels Ctrl+F Show Guides View | Guides "Ctrl+;" 
Frame Insert F5 Snap to Grid View | Grid Ctrl+Shift+´ 
Group Modify Ctrl+G Snap to Guides View | Guides "Ctrl+Shift+;" 
Hide Edges View Ctrl+H Snap to Objects View Ctrl+Shift+/ 
Hide Panels View Tab Step Backward Control , 
Import File Ctrl+R Step Forward Control . 
Info Window | Panels Ctrl+Alt+I Test Movie Control Ctrl+Enter 
Instance Window | Panels Ctrl+I Timeline View Ctrl+Alt+T 
Instance Modify Ctrl+I Undo Edit Ctrl+Z 
Italic Text | Style Ctrl+Shift+I Ungroup Modify Ctrl+Shift+G 
Keyframe Insert F6 Unlock All Modify | Arrange Ctrl+Alt+Shift L 
Last View | Goto End Work Area View Ctrl+Shift+W 
Library Window Ctrl+L Zoom In View Ctrl+= 
Lock Modify | Arrange Ctrl+Alt+L Zoom Out View Ctrl+- 
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